What is JotForm?
JotForm is a free online form builder which helps you create online forms without writing a single line of code. No sign-up required.

At JotForm, we want to make sure that you’re getting the online form builder help that you need. Our friendly customer support team is available 24/7.

We believe that if one user has a question, there could be more users who may have the same question. This is why many of our support forum threads are public and available to be searched and viewed. If you’d like help immediately, feel free to search for a similar question, or submit your question or concern.


  • Profile Image

    The forms are not showing up when using Google Chrome and Internet Explorer

    Asked by NCRDepo on January 02, 2013 at 05:11 PM

    I have a link to my forms on our website.  I utilize a Mac and a Windows machine.  When I click on the link on the Windows machine utilizing Google Chrome and Internet Explorer, my forms do not show up.  However, when I am on my Mac, the form shows up using Safari but not Google Chrome.  Help!

    Screenshot 2 shows the screen with no form.

    Page URL:
    https://www.ncrdepo.com/schedule.html

    Screenshot
  • Profile Image
    JotForm Support

    Answered by jonathan on January 02, 2013 at 05:43 PM

    Hi,

    Please try embedding the form using its iframe code instead. Use this guide -How-to-get-your-Form-s-Iframe-Code.

    Please inform us this still does not work.

    Thanks.

  • Profile Image

    Answered by NCRDepo on January 04, 2013 at 05:51 PM

    Thanks for the help.  I inserted the iFrame code.  It now works great utilizing Google Chrome.  However, the same problem persists utilizing IE.

  • Profile Image
    JotForm Support

    Answered by jonathan on January 04, 2013 at 08:13 PM

    Hi,

    I think it has something to do with the https protocol of your website page. Try also embedding the form using its secure URL like this 

    https://secure.jotform.us/form/22584343670152

    See this guide too -How-can-I-receive-SSL-Submissions 

    Please inform us if the issue persist after trying this.

    Thanks.

     

  • Profile Image

    Answered by NCRDepo on January 04, 2013 at 08:44 PM

    Thank you so much!  I thought it had something to do with the https, but wasn't sure how to correct it.  Your feedback has been most helpful :-)