Problems with PDF Editor

  • Profile Image
    giostarchicago
    Asked on November 07, 2018 at 06:46 PM

     

    Hello,

    Having some issues with the PDF Editor feature of JotForm.

    Please see attached screenshot:

    When I click "Edit PDF Form" for one of the forms, I get the "PDF Form" screen, which just hangs indefinitel

    15416343492018-11-07_1519.png

    Very frustrating - I needed to get a PDF sent to a patient this morning, and need to create ASAP.

     

    Please let me know when this is fixed / what I can do to address the issue.

     

    I have had this issue all day. I tried clearing my browser history, etc. but kept having the issue.

    Nikhil

     

  • Profile Image
    DonaldHag
    Answered on November 07, 2018 at 08:48 PM

    Please provide the URL of the form so we can look at it and provide further assistance. Refer to this guide: https://www.jotform.com/help/401-Where-to-Find-My-Form-URL


  • Profile Image
    giostarchicago
    Answered on November 07, 2018 at 09:02 PM

    Here you go. My account is "giostarchicago"

    https://www.jotform.com/build/81988911745169

  • Profile Image
    DonaldHag
    Answered on November 08, 2018 at 01:19 AM

    Thanks for providing the additional information. I have cleared your form cache and the form should be now showing with no issues.

    1541657907Selection_243.png

  • Profile Image
    giostarchicago
    Answered on November 08, 2018 at 01:05 PM

    Amazing - "clear your cache" is your solution? I've done that three times now. Doesn't do anything...your product is unusable.

    Also - to clarify: it's not an issue of the form appearing. It appears properly, but when I attempt to make any modifications it freezes up on me. 

    Is that a "feature?" That you won't be able to make changes to the PDF form after you generate it?

  • Profile Image
    david
    Answered on November 08, 2018 at 02:01 PM

    The suggestion wasn't to clear your browser cache, what was done was clearing caches on our end.  Though this didn't remedy the issue, it was a potential fix since it seems the issue is unique to that specific PDF.  I am able to reproduce the browser crash but only with that one PDF:

    1541703252Capture.PNG

    With a clone of the form and with any new PDF's, adjusting the layout did work as expected.  I added a new PDF to your form and that one worked as expected.  Try editing the the PDF titled "Test" and see if that works as expected:

    1541703611Capture1.PNG

    1541703636PDFeditor.gif