The dollar sign will not show up in my 'sales tax' field

  • Profile Image
    localcoverageva
    Asked on November 08, 2018 at 04:27 PM

    Hello,

    1) The dollar sign will not show up in my 'sales tax' field, please see screen shot

    2)

    Can you please walk me through using the payment widget?  We use authorize.net and I have successfully added the API key and transaction key.  However, I do not understand how to make the payment widget/feature connect to the 'total amount due' field calculated on the form.  All I see in the settings for the payment widget/feature are 'add product'.  Please advise!

    Thank you so much!


    Screenshot
  • Profile Image
    Jim_R
    Answered on November 08, 2018 at 07:13 PM

    Please make sure the $ sign is in string or text format. The background color of each item corresponds to its data format:

    1. Black background 0-9 - Number

    2. Lightbrown background A-Z - String

    To toggle the data format, just click the $ sign in your condition and it should change its background color from black to lightbrown.

    Your 2nd question was moved to a separate thread to avoid confusion:

    https://www.jotform.com/answers/1637599

    I'll reply to you there shortly.

  • Profile Image
    localcoverageva
    Answered on November 17, 2018 at 03:34 PM

    Hi there, I tried your suggestion about the $ but it is not working, at least in MY preview mode.  Is it showing up in yours?  Any further suggestions?

    Thanks!

  • Profile Image
    jherwin
    Answered on November 17, 2018 at 03:55 PM

    I checked your form and see that the dollar sign in the value calculation field is still not set to string.

    Please click it once to convert it to string or text.
    1542487832before.png

    After you clicked the dollar sign, the result should be like this.1542487911after.png
    Please give it a try and let us know if you need any further assistance.

  • Profile Image
    stephanie allen 
    Answered on December 07, 2018 at 06:31 PM

    Hello, I did change it to string/text mode.  I've checked it and what's happening is after I click save, the change is not saving.  I went back and re-did the change three times with saving and it always reverts back to black when I go back into the condition.  Any suggestions?  Thank you!

  • Profile Image
    jherwin
    Answered on December 07, 2018 at 06:46 PM

    I just checked your form and all of your form calculation widget is blank. Please follow this guide on How to Perform Form Calculation Using a Widget.
    1544226094no calc.png


    Also, please always check if the changes you made to your form is saved.

    Here's a screenshot showing changes I made is saved.
    1544226330saved.png

  • Profile Image
    stephanie allen 
    Answered on December 07, 2018 at 07:15 PM

    Hello,

    The field my question was in reference to is the '6% sales tax' field, which is set up as a condition.  And yes, I am checking to make sure my changes are saved and they are according to the instructions you gave.  Any other suggestions?  Thanks!

  • Profile Image
    jherwin
    Answered on December 07, 2018 at 07:34 PM

    Sorry for the quick answer above. I see now why the "$" sign is not showing in 6% tax field.

    The other fields are calculation form widget while your tax field is short text entry.
    1544229212reason.png

    Please change it into calculation form widget and let us know how it goes. :)