Smartphone view issue - GoDaddy website

  • Profile Image
    newhorizonscanada
    Asked on November 26, 2018 at 10:16 AM

    Hello All,

    I embedded Jotform in my website in GoDaddy, everything is working correctly when browsing via computers, but the form is not completely displayed when browsing via smartphone??

  • Profile Image
    Boris_M
    Answered on November 26, 2018 at 11:58 AM

    What I can suggest you is to send us the screenshot of the Jotform form being added to your website and how it looks when you're browsing via computer and how does it looks like when you are running it through the smartphone. What I would like to add, is to add what type of mobile browser are you using when you're about to see your form being inserted into your website.

    I would suggest you doing the following:

    1) Please check if you are using a fully responsive theme.

    2) Have you checked if adding our widget "Mobile Responsive" is working for you? (please see the picture below)


    1543251290Mobile Responsive Widget.png


    3) If this doesn't help, once you provide us with more details: with your screenshots and link to your form; maybe injecting some CSS code would help you in this case.


  • Profile Image
    newhorizonscanada
    Answered on November 27, 2018 at 10:58 AM

    Hi Boris_M,

    Thanks a lot for your fast response


    This is the code

    1543334164Image_1.PNG


    This the bottom of page from computer


    1543334240Image_2.PNG

    This the bottom of page from Smartphone


    1543334274Image_3.PNG


    This is the widget, but it's not working


    1543334302Image_4.PNG

    Thanks in advance

    Warm regards,

  • Profile Image
    BJoanna
    Answered on November 27, 2018 at 12:32 PM

    If I understood correctly, your embedded form is cut off on mobile devices. 

    I found your website http://www.newhorizoncanada.com/, but I am unable to find the form. 

    Please provide us exact webpage URL where your form is embedded, so that we can test it.

    Also, please try to re-embed your form with the iFrame code, to see if that will resolve the issue.

    Getting the Form iFrame Code