IE7 Error: Pagebreak "next" button does not work

  • Profile Image
    guest_30154180274042
    Asked on January 16, 2013 at 11:23 AM

    In IE7, when clicking the Next button for moving to the next page of our form, an error is occuring on the page and users are unable to move to the next page.

     

    The Error information  is: 

     

    Line: 1096

    Char: 92

    Error: Object doesn't support this property or method

    Code: 0

    URL: http://rim.mlearning.com/cs/order

     

    The error only occurs when the user actually CLICKS on the next button. 

     

    The Link to see the form in question is:

    http://rim.mlearning.com/cs/order

     

    I have read through the forums and have tried to get around the issue by embedding our form using the iframe method with no success.  That attempt can be found here:

    http://rim.mlearning.com/cs/order/index_iframe.html

     

    I have attempted to find anythng out of the ordinary in and around line 1096 of our form, but I can find nothing exotic or invalid.  My best guess is that there is some action that is triggered on the next button click event.  Perhaps a postMessage or some frame-to-parent communication? 

  • Profile Image
    guest_30154180274042
    Answered on January 16, 2013 at 11:37 AM

    Looks like im just a guest, but we're actually premium members! The question submission form didnt pick up my login

  • Profile Image
    EduardoMendez
    Answered on January 16, 2013 at 12:55 PM

    Hi there, 

    Can you please try to embed your form using iFrame code in stead.

    Here is a guide to help you with that:

    http://www.jotform.com/help/148-How-to-get-your-Form-s-Iframe-Code

    Please give that a try and let us know if you need further assistance!

  • Profile Image
    onpoint
    Answered on January 21, 2013 at 02:23 PM

    I have read through the forums and have tried to get around the issue by embedding our form using the iframe method with no success.  That attempt can be found here:

    http://rim.mlearning.com/cs/order/index_iframe.html

  • Profile Image
    Welvin
    Answered on January 21, 2013 at 03:24 PM

    How about changing your doctype declaration into this one:

    <!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Transitional//EN" "http://www.w3.org/TR/xhtml1/DTD/xhtml1-transitional.dtd">

    Please let us know for results.

     

    Thanks