New PDF editor: Star Rating field is not hidden on PDF if it is empty

  • Profile Image
    axxon
    Asked on December 19, 2018 at 10:56 AM

    Hi,

    In order to create a form, I used an existing one and then modified all the questions for the correct text. Now, when a candidate completes a form (Enquesta MyInterview) and the answers are send by email, those in the email body are correct. However, the questions in the PDF attachment are NOT correct. The questions I see in the PDF are those in the original form, the one I cloned to create this form.

    Attaching an image where you will see the answers of the candidate. The questions in the email are correct, those in the PDF are not.

    Thanks.

    Elisabet


    https://form.jotformeu.com/83501837315354 https://form.jotformeu.com/83501837315354https://form.jotformeu.com/83501837315354https://form.jotformeu.com/83501837315354https://form.jotformeu.com/83501837315354)

  • Profile Image
    Victoria_K
    Answered on December 19, 2018 at 01:01 PM

    Hello Elisabet,

    It seems that upon changing fields labels on your new form, you need to also update PDF template. You can open your form in PDF editor using the link provided below: 

    https://www.jotform.com/pdf-editor/83501837315354 

    Please let us know if you will need more help with this.

  • Profile Image
    axxon
    Answered on December 20, 2018 at 08:16 AM

    Hi Victoria,

    I didn't make any changes to the PDF editor but it looks like that the questions are correct now (not the ones from the original form). Maybe it got updated automatically?

    The only issue I see now is that I have 2 star-ranking questions in the form, but we only show 1 to the candidate (based on their election on question 1). Therefore, they only see and answer one question, why are both of them showing up in the PDF attachment?

    Thanks.

    Elisabet

  • Profile Image
    Victoria_K
    Answered on December 20, 2018 at 09:54 AM

    Hello Elisabet,

    I can see that PDF template is set to hide empty form fields. It seems that the unfilled star rating field is not considered as empty. I will report this problem to our developers for closer checking. We will keep you informed via this thread.

    Thank you for contacting us on this matter.

  • Profile Image
    axxon
    Answered on December 20, 2018 at 09:55 AM

    Thank you Victoria!

  • Profile Image
    Elisabet
    Answered on January 17, 2019 at 08:09 AM

    It looks like this is not happening anymore. Can you confirm that the issue has been fixed?


    Thanks.


    Elisabet

  • Profile Image
    axxon
    Answered on January 17, 2019 at 08:19 AM

    False alarm, this is still happening. I completed the form again and the rating questions (with stars) is not showing up in the PDF attached to the mail I received. Earlier, this was showing up twice, now it is not showing up.

    Do you know when the issue will be fixed?

    Thanks.

    Elisabet

  • Profile Image
    Victoria_K
    Answered on January 17, 2019 at 09:40 AM

    Hello Elisabet, This ticket was created for the issue when Star Rating field was not hidden on PDF if it was not filled. I have checked this on my test form and can confirm that this bug was fixed. 

    It seems that you are experiencing different problem with your form. Could you please let us know which form we should check? We will wait for your reply. Thank you!

  • Profile Image
    axxon
    Answered on January 18, 2019 at 04:33 AM

    Hi Victoria,

    The issue now is that the PDF I receiv with each form answered doesn't have the correct information. To reproduce:

    - I completed the form: https://form.jotformeu.com/83501837315354

    - After it was completed, I received an email. The fields in the email body are not correct. Instead of showing the questions the user answered, it shows old questions (to create this form, I cloned another one I had). This issue happens with the 2 questions asking for a 1-5 rating and the last question. See screenshot attached. 1547803834form.JPG

    - The information I see in the PDF attached it is correct.

    Should I just make the changes to the -email notification manually? It is my understanding that this should be updated automatically.

    Thank you!

    Elisabet

  • Profile Image
    Richie_P
    Answered on January 18, 2019 at 09:19 AM

    I have moved your questions to a new thread to assist you better.

    Kindly follow this link https://www.jotform.com/answers/1704952-

    Thank you.