Jotform Integration with Google Sheets stuck in Integrating

  • Profile Image
    manoverboard735
    Asked on January 09, 2019 at 12:32 AM

    Hello,

    I am trying to link my Jotform with the Google Sheets integration but after I authenticate my Google account and press Complete Integration, the page simply gets stuck while the page says "It may take a while! We're integrating your data." I have waited over an hour and nothing has changed, this is for a newly created form so there is little to no existing data for this form.

     

    Thanks,

    P

  • Profile Image
    Welvin
    Answered on January 09, 2019 at 03:54 AM

    I cannot replicate this with a cloned version of your form here https://form.jotform.com/90082370817961

    Spreadsheet link: https://docs.google.com/spreadsheets/u/1/d/12I_ThKrRPT1VlC2QgQ3l9x1Qdv_OQbCVQmY5eyGFXWc/edit

    Please reload the form builder, and make sure that you are still logged in. If the issue persists, please check your browser console for possible related errors;

    https://www.jotform.com/help/453-How-to-get-a-console-report-from-most-common-browsers

    Get back to us with a screenshot of the console area.

    https://www.jotform.com/help/438-How-to-Post-Screenshots-to-Our-Support-Forum 

    Also, try doing the integration using your other browser. 

  • Profile Image
    manoverboard735
    Answered on January 09, 2019 at 11:21 PM

    I tried it on a different browser and it didn't work either. I found an error in the console area, here is the screenshot for Firefox:

    1547093537bug.PNG

    the one from Chrome:
    1547093860bug2.PNG

    and the one from Microsoft Edge:
    1547094075bug3.PNG

    I have searched the internet for solutions to this but nothing online has worked.

  • Profile Image
    manoverboard735
    Answered on January 09, 2019 at 11:26 PM

    Here is a screenshot of a cleaner and expanded error from Chrome:
    1547094346bug4.PNG

    Looks like it could be a post error on Jotform's side, how do I fix this.

  • Profile Image
    manoverboard735
    Answered on January 10, 2019 at 12:07 AM

    I don't mean to overwhelm you with screen captures but I had a friend try it on his computer and he also got an error, here's a screenshot of that:

    1547096835WhatsApp Image 2019-01-10 at 1

  • Profile Image
    Welvin
    Answered on January 10, 2019 at 03:32 AM

    Your 3rd screenshot from Edge and last two screenshots including the one from your friend are related to the network. Well, 404 means a problem to the requested page, and it is to us, but the other errors need to be checked to your end.

    Are you connected to a school or a private network? Because I tried doing the integration straight to your form and I was able to do it. Please check your network to see if it is not blocking your connection with Jotform. If it's blocked, the integration will not proceed since it requires a connection with your Jotform account. 

    Also, check your anti virus or browser extensions related to security/privacy. Try disabling them to see if that will fix the problem. You may need to add an exemption. 

  • Profile Image
    manoverboard735
    Answered on January 10, 2019 at 08:33 PM

    I am not connected to a school network, I am simply connected from home, this is the same for my friend. I cannot understand how this could fail both for him and for me. I have looked over the firewall settings, turned off my ad blocker, and restricted Bitdefender and yet I'm still getting the same errors. Not really sure what else to do here, I'm running out of ideas

  • Profile Image
    BDAVID
    Answered on January 10, 2019 at 10:45 PM

    Please try clearing your browser's cache. Let us know if that helps.

  • Profile Image
    Paul Nieto 
    Answered on January 10, 2019 at 11:44 PM

    I forgot to mention in that previous post but I also had already cleared the cache. Now I'm pretty consistently getting a 404 error now (I believe) on chrome. If you'd like I can post a screenshot of that.

  • Profile Image
    BJoanna
    Answered on January 11, 2019 at 02:47 AM

    I am also unable to replicate the issue you reported. Can you please test the integration using some other network? You can also try with some other Google account. You can also provide us a screenshot from Chrome.