Will the JotForm embed plugin for WordPress be updated?

  • Profile Image
    maydmtech
    Asked on January 09, 2019 at 03:18 AM

    Neither plugin has been updated in two years, nor are they tested with the current version of WP. I attempted to install the Embed plugin and whenever I clicked on the pencil it said File not found. Will either plugin be updated to reflect the current version of WP?



    This is a re-post of a comment on A Guide to Embed Forms for WordPress Users

  • Profile Image
    Kiran
    Answered on January 09, 2019 at 07:28 AM

    I see that the WordPress plugins are not updated recently. However, if you want to embed the form on your WordPress website, you may consider embedding using the default Javascript embed method which should be working fine. 

    1547036684EmbedJavascriptV4.png

    You may try embedding the form using iframe embed method by following the steps in the guide below:

    https://www.jotform.com/help/148-Getting-the-form-iFrame-code 

    Did you try using any of the plugins on your WordPress website and experiencing any issue? If so, please provide us with more information so that we can forward the issue to our backend team for further investigation.

    Thanks!

  • Profile Image
    maydmtech
    Answered on January 09, 2019 at 10:09 AM

    Per my previous post, I attempted to install the Embed plugin and whenever I clicked on the pencil it said File not found.

    I already embedded the form via JavaScript and that worked fine.

  • Profile Image
    maydmtech
    Answered on January 09, 2019 at 10:10 AM

    Per my previous post, I attempted to install the Embed plugin and whenever I clicked on the pencil it said File not found.

    I already embedded the form via JavaScript and that worked fine.

  • Profile Image
    Kevin_G
    Answered on January 09, 2019 at 11:26 AM

    Glad to know the default embed method worked for you. 

    I will consult with our developers if there are plans to update the embed plugins on WordPress, we will keep you updated via this thread. 


  • Profile Image
    maydmtech
    Answered on January 09, 2019 at 12:04 PM

    Thank you.

  • Profile Image
    NeilVicente
    Answered on April 10, 2019 at 01:42 PM

    Hi there,

    We have fixed this issue for the classic editor.

    Gutenberg compatibility, however, is still in the works.

    We'll let you as soon as it becomes available.

    Kind regards,