E-Signature not working on Microsoft Surface

  • Profile Image
    capitaldentures
    Asked on January 13, 2019 at 12:16 AM

    Hello

    I created a form and require an e-signature using the Microsoft Surface pen on a Microsoft Surface. I have tried all the widgets for signatures but they all behave the same way, unable to draw the signature in the box. The surface tends to recognise this area as a single click using finger or a pen and will not draw the signature unless the right click button on the side of the pen is pushed down. This is inconvenient but also odd behaviour, given that the same form on an iPad works just fine.

    Is there a known issue with Surface support? I've tried it in Chrome and Edge on the surface and get the same behaviour, so I'm thinking this is device specific to the Surface.

    Please advise.

  • Profile Image
    jonathan
    Answered on January 13, 2019 at 02:36 AM

    Thank you for providing us in depth details of the issue. Unfortunately I do not have the specific hardware device MS Surface to test in actual and check the problem of the Signature widgets.

    I tried searching our support forum for similar case, but no similar reported issue on the result. Most of the related post suggest the E-signature widget was working just fine on the specific device, as the form is more specific on the browser instead. Meaning if it work on the browser on other device, it should also work on another device using similar browser.

    I have elevated this thread to the next level for further investigation. I am sure the back end team have the specific hardware needed to test and debug the E-signature widget.

    We will notify you here for any status updates when available.

    We apologize for any inconvenience caused.


  • Profile Image
    NeilVicente
    Answered on August 25, 2019 at 07:13 AM

    Sorry for the late update, but this bug has been fixed for quite some time now.

    Please do try again and let us know how it goes.

    Regards,