How do I get a picture to show on Facebook when sharing my form?

  • Profile Image
    deckerspence
    Asked on January 17, 2019 at 06:40 AM

    see pic. How do I get a picture or background to show behind the survey title. I had done this before with Survey Monkey - and my post was more visually appealing. Pic of that also provided. Notice there was a graphic (important in FB posts I hear) and also some additional words I was able to add.

  • Profile Image
    Welvin
    Answered on January 17, 2019 at 09:42 AM

    You need to add the image in the form, preferably using our Image field. Facebook will automatically fetch the image as the post image. If not, debug the form through this page before sharing it again:

    https://developers.facebook.com/tools/debug/ 

  • Profile Image
    deckerspence
    Answered on January 17, 2019 at 09:59 AM

    Thank you Welvin; I will try this. Is there a way for me to add additional words like shown on this pic?

  • Profile Image
    Welvin
    Answered on January 17, 2019 at 11:19 AM

    Unfortunately, you cannot add the description. If you would like to customize the image, the name, and the description, I would suggest embedding the form on your website, and optimize your OG properties there.

    If you do not have a website, I would suggest adding a message separately in your post, and add the description in the post box

  • Profile Image
    deckerspence
    Answered on January 18, 2019 at 07:12 AM

    I added an image field. I tested creating a FB post using the post to social media button you provide. I do not see the image appearing in the post. Can you please take a look and tell me what I did wrong?

  • Profile Image
    Welvin
    Answered on January 18, 2019 at 09:34 AM

    The image will appear as a thumbnail after you post the link. Example:

    It is very limited this time. You cannot change the OG Properties of the form, so my suggestion would be to embed the form on your website. If you do not have a website, you have to add the image manually in the post including the description.

  • Profile Image
    deckerspence
    Answered on January 18, 2019 at 09:51 AM

    The pic you shared of how this will appear is just fine for me. Thanks so much.

  • Profile Image
    deckerspence
    Answered on January 18, 2019 at 09:53 AM

    Huh - It did not appear like the image you shared. Please tell me what I did wrong. I went to "share on FB" - choose a group - and it appeared without the image.

  • Profile Image
    Welvin
    Answered on January 18, 2019 at 11:17 AM

    I cannot replicate the problem. In fact, your image appears to have been changed now and showing in full on my Group:

    Can you try again? 

  • Profile Image
    deckerspence
    Answered on January 18, 2019 at 12:45 PM

    I did change the image. I went to a group and put into the body of the post: https://form.jotform.com/90154442760150.  I do not get the image. Here is what it looks like - no pic.



    15478335272019-01-18_12-43-48.jpg


  • Profile Image
    Welvin
    Answered on January 18, 2019 at 01:18 PM

    My apologies for not explaining. That is just the preview window. I don't know why the form is not showing the image on preview, but once you posted the form, you should see the image. Please try that.

  • Profile Image
    deckerspence
    Answered on January 18, 2019 at 01:24 PM

    I had tried that before with the same result. I just tried it again with the same result - plain jane, no pic.

     

    (It has been my experience that what is shown in the preview pane is what shows in FB.)

     

    15478367872019-01-18_13-22-35.jpg

     

     

  • Profile Image
    Welvin
    Answered on January 18, 2019 at 01:38 PM

    I've already debug your form, and got the image displayed in the post. 

    I think that's maybe Facebook is restricting this to some users. Or maybe your Facebook group settings do not allow embedded contents or do not allow images? Can you check that?

    How about posting the Form on your Facebook wall? 

  • Profile Image
    deckerspence
    Answered on January 18, 2019 at 02:05 PM

    Same result when I tried that earlier.

    I just now logged out of JotForm and back in again and tried and now it worked.  Gremlins. Thanks.