How do I fix the broken link? Or, have I gone over some amount so that the form won't pull up for people?

  • Profile Image
    patgarrett789
    Asked on January 29, 2013 at 09:50 AM

    We are using the jotform for all of our admissions to our Montessori Charter School. The deadline is Feb. 15. It stopped working two days ago and I can't figure out how to remedy it. Help please.

     

  • Profile Image
    jonathan
    Answered on January 29, 2013 at 12:01 PM

    Hi,

    When I click on the link in your website, the form open properly on my end.

     

     

    Please inform us if you are still having this issue.

    Thanks.

  • Profile Image
    patgarrett789
    Answered on January 29, 2013 at 12:30 PM

    It's still not working for me and I've tried it from 5 different computers on two different systems.

    pg

  • Profile Image
    EduardoMendez
    Answered on January 29, 2013 at 01:04 PM

    Hi there, 

    Our apologies as we experieced a temporary issue with our serviers earlier today.

    I have cleared the cache on yuor forms on our end.

    Is this issue persisting?  I have cleared the cache on your forms and things should be back to normal.   Please let us know and thank you for your patience!

  • Profile Image
    patgarrett789
    Answered on January 29, 2013 at 01:16 PM
    It's working! I also restarted my computer just in case. Thanks for the
    prompt attention. We love jotform and are depending on it daily. Much
    obliged.
    -Pat
  • Profile Image
    moonzkie
    Answered on January 29, 2013 at 02:01 PM

    Glad to hear that everything is working fine now. Thank you for such nice words and for using JotForm.