Question is not showing up on PDF form

  • Profile Image
    CurranAssociatesCPA
    Asked on January 28, 2019 at 11:59 AM

    We have recently added another question to our Jotform and it is visible on the actual form and when it is submitted. However, when I try to download the PDF form, the question/answer does not show up. Did I miss a step when adding the question or is there something that needs to be done so it can show up on the PDF version? Thanks!

  • Profile Image
    Nick_So
    Answered on January 28, 2019 at 12:13 PM

    It will be great if you could provide us the exact question which you have added recently and is having this problem so that we can investigate accordingly.

  • Profile Image
    CurranAssociatesCPA
    Answered on January 28, 2019 at 12:14 PM

    Exact question is:


    Is your health coverage under a High Deductible Health Plan (HDHP) with an option for a Health Savings Account (HSA)?

  • Profile Image
    Nick_So
    Answered on January 28, 2019 at 01:40 PM

    I have checked this by going to My Forms >> Selecting the form >> View Submissions >> Download as PDF.

    1548700435The Easiest Online Form Builde


    1548700528Jotform · Submissions_ Clone

    After downloading the PDF I can see the answer to this question:

    1548700628Clone_of_2018_Tax_Questionnair


    Are there are any specific steps that you follow other than this, then please let me know so that I can try to replicate this and proceed accordingly.

  • Profile Image
    CurranAssociatesCPA
    Answered on January 28, 2019 at 01:45 PM

    My steps were slightly different in saving the PDF. In submissions, I would highlight the form that I want to be downloaded, click PDF on the top left (next to print and reply), then select download PDF. By doing this process, I do not see the question or answer. Let me know if I'm missing a step or if I need to change the process of downloading the PDFs.

  • Profile Image
    Nick_So
    Answered on January 28, 2019 at 02:00 PM

    I have followed the same steps that you have mentioned and I am still able to find the question. Please refer to the screenshots below:

    1548701810Jotform · Submissions_ Clone  1548701823PDF Editor - Google Chrome 201

    Can you please try to submit the form one more time and check? Please let us know if the issue is still persisting. Make sure that you clear the Form cache and browser cache before submitting the form.

    Reference link: How-to-Clear-Your-Form-Cache

  • Profile Image
    CurranAssociatesCPA
    Answered on January 28, 2019 at 02:10 PM

    I went ahead and cleared the form cache before resubmitting another form. The question is still not showing up on the PDF version, but I can see it on the email submission. See attached screen shots

    1548702596Annotation 2019-01-28 110813.j1548702622Annotation 2019-01-28 110717.j

  • Profile Image
    EltonCris
    Answered on January 28, 2019 at 04:10 PM

    Were they from the same submission?

    I can see a few test submissions in your form and some of them do not have answers on the field mentioned. 

    Just FYI, empty fields are not shown on the PDF by default.

    Try the submission made by Patricia, you should be able to see the mentioned field.

    https://www.jotform.com/pdf-editor/90036599502156?submission=4243748017406327805

    If you want empty fields to show on the PDF too, uncheck this option in the PDF settings on the PDF Editor.


  • Profile Image
    CurranAssociatesCPA
    Answered on January 28, 2019 at 04:38 PM

    Yes, they were from the same submission. Even when I answered "yes" on the test submissions, it still did not show on the PDF. For Patricia's it was done as a multiple choice...I then deleted it and made it a single choice to match the rest and then it stopped showing on the PDF. Also when the form was under "multiple choice" it showed however, it duplicated the same question 4-5 times at the bottom of the form.


    I understand the empty fields are not shown, but it should still show it the client marks "no" is that correct? It does that for our other questions/answers.

  • Profile Image
    EltonCris
    Answered on January 28, 2019 at 05:53 PM

    I just would like to clarify that deleting a field also deletes its associated submissions data. If you have done that, I'm afraid your existing submissions for that particular field are also deleted. This means that they will not show on the PDF anymore considering that they were empty.

    However, for the new submissions, you should be able to see them but I would suggest doing the following,

    1. First, I suggest resetting your PDF document into its default layout.

    To do that, delete the existing PDF Document in your form in the PDF Editor then create a new one.


    This is also to sort the duplicate fields issue at the bottom of the PDF.

    2. After these changes, make a new test submission on your form. You should be able to see the field even when NO is selected.

    Let us know how it goes.

    Thanks