HIPAA Account: User can login with old password and new password and this causing bug in the account.

  • Profile Image
    Dustin Molieri 
    Asked on January 31, 2019 at 08:34 PM

    This is my third attempt to get this issue resolved. My support experience has been presumptive, closing the tickets before the issues are resolved. If this happens again, game over.

    If you like, I can create a public YouTube video which demonstrates all of the issues I am experiencing (2 of which are critical)? That would probably generate negative publicity for JotForm, so I'm sure it'd be ideal for both of us not to do that.

    1) When I go to www.jotform.com and attempt to login with my account "dmolieri@coic.org", it will not accept my current password, but rather my old password.

    2) After logging in with my old password, it displays that I have no forms. It does not show my account logo in the top right corner of the screen. To fix this, I have to login a second time with the same username, but a different password.

    3) If I attempt to login with my new password at the first login, it says it is incorrect.

    4) If I go to hipaa.jotform.com and login from here, it accepts my new password the first time every time.

    I have:

    A) Reset Browser History and Cache

    B) Tried with a different web browser

    C) Tried in Incognito Mode / Privacy Mode / Private Window mode on Chrome, Edge, and Firefox. The same issue exists.

    5) This started after I set up HIPAA and paid for a full year of form hosting with a BAA. After doing this, I changed my password. Ever since changing my password, this issue has been occurring where I have to login multiple times using different passwords in order to get to my forms.

    6) This is not a client-side issue, this is a server-side issue. The system obviously has two methods of authenticating, one for HIPAA accounts and another for traditional accounts. Both systems have the same username, but different passwords. This is the only explanation as to why I have to enter one password for initial login, and another to get to my forms.

     

    Issue 2)

    When I go to hipaa.jotform.com, and login, I see my forms. After I create a form, I cannot go back and edit the form. When I click edit, it displays the form in full screen as though I were submitting the form, but does not give me the edit options. I am not in "preview" mode and there is no option to disable "preview" mode.

     

    With this, I cannot edit a form after I log out of jotform. Once I log out and go back in, it will not let me edit the form.

     

    Issue 3)

    No matter how I log in, the account sometimes shows my account image but other times does not. When it does not, and I click my account, I am then prompted to enter my password again to get my account settings to appear. When I leave, and go back to forms, I must then enter a password again to get my forms.

     

    If you cannot resolve this, then I have to assume this is "expected product behavior" and JotForm is meant to be glitchy and require you to guess which password to use and requires you to enter passwords multiple times to do anything and its supposed to be hit or miss when logging in and I'll have to assume that jotform does not want you to edit forms after you create them.

    If you cannot resolve this, I want my money back. I do not pay for things that don't work.

  • Profile Image
    jherwin
    Answered on February 01, 2019 at 01:05 AM

    Hey Dustin - Please accept my apology and we are sorry for the trouble caused to you. I read all the messages above and decided to escalate it to our developers because even I or other support can't access HIPAA compliant account. Also, you've done the troubleshooting required so I think this is enough to pass it to our second level.

    However, I just want to correct something. You said we closed the ticket even though the issue was not fixed yet. We are setting the threads private if the user posted a ticket with their email address to ensure the safety of your account. However, setting threads as private does not mean that you can not reply to the ticket, simply open the thread through the email you received then you can post your reply again.

    On your first thread - https://www.jotform.com/answers/1673965, this thread is not set as private so you can always post your reply here.

     In the second thread - https://www.jotform.com/answers/1713027, it is set as private as I said to ensure the safety of your account and email address.

    I have now elevated this issue to the next level support so that they can investigate the problem. We will notify you here and on your email at once when a status update is available.

    By the way, I will not set this thread private so you can reply or post your reply again. Thank you for your understanding.

    Thread: https://www.jotform.com/answers/1719696.

  • Profile Image
    dmolieri
    Answered on February 01, 2019 at 11:43 AM
    Thank you for responding.
    I look forward to getting this issue resolved as quickly as possible. We
    have a new website that is waiting on these forms before it will go live.
    This is all its waiting on.
    -- Dustin
    ...
  • Profile Image
    Denis
    Answered on February 04, 2019 at 04:14 AM

    Hello,

    We are sorry for the inconveniences caused. We have investigated the issue, and we found the root cause. Two different passwords are saved on our servers due to a glitch. To fix this issue, please reset your password and let us know if the problem persists on your side. 


    Thank you.

  • Profile Image
    dmolieri
    Answered on February 04, 2019 at 01:43 PM
    Greetings,
    Upon changing our password, when logging in with the new password, this is
    what I get:
    [image: image.png]
    When I click login again from here, and using the new password, this is
    what I get:
    [image: image.png]
    So the first login let me log in without issue, but does not display any
    forms. When I click login the second time, it will not let me login using
    my new password. On a whim, from here, I am going to try my old password...
    ... Success. When I used my old password, I get:
    [image: image.png]
    However... now when I go to edit a form as displayed here:
    [image: image.png]
    Watch what screen I get after clicking edit:
    [image: image.png]
    Instead of being able to "Edit" the form, it is taking me into the form as
    though I were a client filling out the form. You can see there is no
    "preview on/off" switch here.
    If I create a new form, I can add / remove and edit form fields, rules,
    etc, but the minute I log out of JotForm and log back in, I will no longer
    be able to edit.
    Your help is appreciated. The issue is not yet resolved after changing my
    password.
    -- Dustin
    ...
  • Profile Image
    Richie_P
    Answered on February 04, 2019 at 03:00 PM

    Thank you for testing it out. It seems your screenshot did not go through.

    Kindly follow this guide on posting screenshots in the thread:-How-to-add-screenshots-images-to-questions-to-the-support-forum

    I will let the assigned developer know that the issue still persist.

    They will contact you once updates are available.


  • Profile Image
    dmolieri
    Answered on February 08, 2019 at 02:43 PM
    Can I get a status update on this?
    Also, can you clarify: do you need me to send the screenshots or were the
    descriptions thorough enough?
    ...
  • Profile Image
    Richie_P
    Answered on February 08, 2019 at 03:19 PM

    The issue is well stated in the description, the screenshots may not be needed.

    Unfortunately, updates are not available at the moment.

    Our developers will contact you once updates are available.

    Thank you for your patience and understanding.




  • Profile Image
    dmolieri
    Answered on February 15, 2019 at 05:43 PM
    Your 1 week is up,
    Please refund the credit card on file which was used to make the purchase.
    I was not lying when I said this is your last chance before a refund.
    Thanks,
    - Dustin
    ...
  • Profile Image
    jherwin
    Answered on February 15, 2019 at 06:59 PM

    Hey Dustin - We are very sorry if the issue takes too long to resolve. I have canceled your subscription for your account and issued a prorated refund ($240.23), it should be reflected on your account within 5-10 business days.

    Again, we are sorry for the trouble caused to you. This ticket is still open, we will still update you regarding this issue.

    Thank you!

  • Profile Image
    dmolieri
    Answered on February 18, 2019 at 06:43 PM
    I believe this should be pro-rated for 3 additional months as I have not been able to use the service since November.
    Sent from my iPhone
    ...
  • Profile Image
    jherwin
    Answered on February 18, 2019 at 07:55 PM

    I will send this thread to our billing team for further review. We will update you on this thread once update is available.

    Thank you :)

  • Profile Image
    Denis
    Answered on February 19, 2019 at 02:44 AM

    Hello,

    Sorry for the late response, due to replication your password was failing. We have set your account password to the last password you are set. We are sorry for the inconveniences caused.


    Regards.

  • Profile Image
    jherwin
    Answered on February 26, 2019 at 01:08 AM

    Hey Dustin - We only charge you worth of 2months subscription ($65) and refunded the rest.

    Thank you for your patience.