Email send not working for form

  • Profile Image
    littlemastersclub
    Asked on March 05, 2019 at 06:45 PM

    https://form.jotform.com/90294336515155

     

    was working previously but doesn't seem to be working now. Can someone help take a look? This is relatively urgent! Thanks!

     

    Mei 

  • Profile Image
    EltonCris
    Answered on March 05, 2019 at 08:46 PM

    The form is working when I check it here. Can you give us more details about the problem?

  • Profile Image
    littlemastersclub
    Answered on March 05, 2019 at 11:36 PM

    i have couple emails set up to be sent under different conditions. I'm not getting any of them. One is "request received" which is the second email in my email list. It's supposed to be auto responding email to whoever submit the form. I'm not getting that one either. 

  • Profile Image
    ashwin_d
    Answered on March 06, 2019 at 01:05 AM

    I am sorry for the trouble cause to you. Have you made any changes in the form's condition or added new condition?

    I did check your form and found that though you have added 3 form auto-responder email alerts but you have also added conditions for these auto-responders to send email. The fields which you have added in condition is actually hidden form fields. Are you trying to send auto-responder email after you edit submissions?

    We will wait for your response.

  • Profile Image
    littlemastersclub
    Answered on March 06, 2019 at 01:34 AM

    Does it matter if the fields in the condition are hidden fields? 

    This is an expense reimbursement form. The hidden fields are for the approver and bookkeeper. We don't want the person submitting the request to see or edit those fields when they first come in to fill out the form.

    We want to send the submitter auto response only the first time they submit the reimbursement request. Then the approver and bookeeper will come in and see the hidden information to fill out the approval and payout information. 

    Does that help? let me know if you need more information. Thanks!

  • Profile Image
    ashwin_d
    Answered on March 06, 2019 at 02:32 AM

    No it does not matter to trigger condition if the fields are hidden but since you have added condition in form to send auto-responder email only when the fields are filled in. Since users are not able to see these fields and by default these fields are empty field, the condition is not triggered. They will trigger when you edit edit the submission and filled in hidden form fields.

    I would suggest you to please add a new form auto-responder email alert in form and set it to send email to user who submitted form. You do not have add any condition for this to ensure it is sent when the form is submitted by user. The following guide should help you how to add form auto-responder in form:  https://www.jotform.com/help/26-Setting-up-an-Autoresponder-Email 

  • Profile Image
    littlemastersclub
    Answered on March 06, 2019 at 02:35 PM

    I disabled the condition on the hidden fields and it's sending the emails fine now. I still don't understand why, but it seems to be working now. Thanks for your help!