Not Receiving Submissions for New Form

  • Profile Image
    permissions_books
    Asked on March 13, 2019 at 09:07 AM

    Hello,

    I just created a new form in our account and upon testing, I see that we are not receiving the test submissions in Salesforce. I set up the notification email the same as the other forms (links below), all which we are receiving submissions successfully. Not sure if I'm missing something. Can you please check?

    Existing Form: https://www.jotform.com/permissions_books/wolters-kluwer-disability_form

    Existing Form 2: https://www.jotform.com/permissions_books/WK_BooksRequest

     

  • Profile Image
    Alan_D
    Answered on March 13, 2019 at 12:02 PM

    I have reviewed your form. You have tested your form with two submissions.
    1552491903Jotform · Submissions_ ASAM F
    A conditional notification email is also defined.
    15524919272.png
    Both submission emails have been sent.
    15524921111.png
    Can you check your notification email condition?
    Also, your form is not integrated with Salesforce. Can you check the integration? You must integrate it before submitting.
    15524928223.png

  • Profile Image
    permissions_books
    Answered on March 13, 2019 at 12:16 PM

    I did receive the first submission (#0677) based on the conditional statement, but not the second submission to permissions@lww.com. I don't believe any of of the other forms are integrated with SF and they're working fine. I rather not interrupt the process for those that are working so I'm not sure if this is a SF issue that's preventing the requests from coming into SF.

  • Profile Image
    Alan_D
    Answered on March 13, 2019 at 01:56 PM

    I think you just created this form. Salesforce integration must be done separately for each form. You need to add salesforce integration to your new form.
    Salesforce integration of your previous forms does not appear. But the sending submissions to salesforce is unusual.
    Your second submission(#2986) email has been sent. Would you please check your spam/junk boxes?
    15524994991.pngYour email history can be found on your settings page.
    15524995912.png

  • Profile Image
    permissions_books
    Answered on March 18, 2019 at 12:38 PM

    I contacted my internal Salesforce team to understand the issue. I'm not sure why this is happening specifically for this form and not the other forms. She submitted a question on Friday and told me to contact you since I'm the form owner.

    https://www.jotform.com/answers/1762686-Notification-missing-line-field-after-only-1-field-

    The issue is when the field value says "Email," Salesforce cannot parse the email address.

    However, when the field value is changed to "E-mail", the issue then becomes with the Jotform notification. Salesforce does try to extract the email but because the Jotform notification concatenates the E-mail with the next line in the notification, Salesforce extracts an invalid email address (see screen shot below).

    1552926117Email_JF_ASAMForm.JPG


    Is there something on the back end why there is no line feed or spacing in between the E-mail and Contact Phone Number?

    I have a few other forms that need to be launched and I'd like to get this resolved before we launch additional forms.

  • Profile Image
    david
    Answered on March 18, 2019 at 01:49 PM

    I checked the form you referenced:

    https://form.jotform.com/permissions_books/ASAM_Form

    And did not see the text you are referring to in any of the emails that were set up. 

    1552931273Capture.PNG

    Is that the correct form to check? Let us know and we can take another look.  If you are trying to pull the data into Salesforce via email, it might be easier to connect the integration directly instead of forwarding to Salesforce via email:

    https://www.jotform.com/help/271-Flexible-Data-Integration-With-Salesforce

  • Profile Image
    permissions_books
    Answered on March 18, 2019 at 02:47 PM

    Yes, that is the correct form.

    The screen shot is the notification being attempted to be sent to SF but it was having errors due to not having a line or space between email and contact phone number so SF cannot extract the email.

    I hope this clarifies the situation. Can you help?

  • Profile Image
    Kevin_G
    Answered on March 18, 2019 at 04:24 PM

    We understand the issue; however, it's a bit unclear how you are generating the email: 

    1552926117Email_JF_ASAMForm.JPG

    If you're generating that email on your end, we would recommend you to add the missing character, you should be able to do this while mapping the fields on the email you're sending, note that it's a bit hard for us to know how to resolve the issue when the code is not hosted in one of our apps or integration. Also, as my colleague explained you can perform the integration using our native app, here is a guide that will help with that: https://www.jotform.com/help/321-Mastering-SalesForce-with-JotForm 

    Thanks.