Thank You page: Redirecting to *.net not working

  • Profile Image
    marinabarnes
    Asked on March 15, 2019 at 12:56 AM

    Jotform does not recognize *.net as a legitimate website and you get a connection error when you try to link an external website with *.net after you click on the Submit button.

  • Profile Image
    BJoanna
    Answered on March 15, 2019 at 03:15 AM

    To which form is your issue related to? I inspected your Senior Beach Day 2019 (draft) form and you are not using Redirect to External link option. 

    Setting up the Thank You Page

    Please provide us a link of a form to which this issue is related to and provide us a .net URL to which you want to redirect your users. 

  • Profile Image
    marinabarnes
    Answered on March 15, 2019 at 10:32 AM

    Here is link to form:  https://form.jotform.com/marinabarnes/senior-beach-day-2019


    I took out link because it wasn't working. The link is www.lghs.net. I thought it doesn't work with a *.net link because when I put in www.saratoga.org, it did work.

    However, maybe it's not *.net in general but specifically, either jotform cannot connect to www.lghs.net

    or www.lghs.net cannot connect to jotform; probably the latter?


    Thank YOU.

  • Profile Image
    BJoanna
    Answered on March 15, 2019 at 11:56 AM

    I am getting the following error when trying to open the link you provided.

    1552664927net.PNG

    So, it seems that the issue is not related to JotForm. Is that a valid domain? Does it have restricted access? 

  • Profile Image
    Marina Barnes
    Answered on March 15, 2019 at 01:01 PM

    It is a valid domain as it is the website of a high school in our district.  If you type "lghs.net" in google, it will get you to the website.  It is a public domain website for sure!

  • Profile Image
    BJoanna
    Answered on March 15, 2019 at 02:20 PM

    It seems that "This site can’t be reached" issue is on my end. I checked with one of my colleagues and he was able to load your page. He also tested your form and got a privacy error message on submit. This issue seems to be related to the https link you added on the Thank You page settings. 

    1552673767https.PNG

    Your website is not SSL (HTTPS). Please change the link on the Thank You page from https://www.lghs.net to http://www.lghs.net and test the form again. 

  • Profile Image
    marinabarnes
    Answered on March 15, 2019 at 02:27 PM

    That's interesting as https is added my jotform not added by me, I believe.  Anyways, removing the "s" from https worked and is now redirecting to the site.


    Thank YOU so much for all your help on this and other requests I have submitted.  You have been the really really/most helpful!!


    With gratitude,

    Marina

  • Profile Image
    BJoanna
    Answered on March 15, 2019 at 03:01 PM

    We are glad to hear that your issue is resolved. 

    Feel free to contact us if you have any other questions or issues. 

  • Profile Image
    marinabarnes
    Answered on March 15, 2019 at 03:21 PM

    Thank YOU again for all your help!!