Language selection not visible in some browsers

  • Profile Image
    Sander Demaré
    Asked on March 18, 2019 at 04:04 PM

    Hello,

    The language selection button in the following buttons does not appear anymore in Internet Explorer :

    https://form.jotformeu.com/82101773597360

    https://form.jotformeu.com/82103548597362

    We only had this problem recently. The problem does not occur with Chrome.

    Do you have any solution for this?

    Thank you in advance,

    Sander

  • Profile Image
    denis_calin
    Answered on March 18, 2019 at 06:39 PM

    Hello Sander,


    Thank you for letting us know about this issue. I was able to replicate it on our end and can see that the language selector button does not appear in Internet Explorer. The button does work in the following browsers: Edge, Firefox, Chrome and Opera. 


    I will be relaying this issue to our developers so that we can find a solution to this problem. Please do not hesitate to contact us if this issue persists, or if you have any other questions or concerns. 



    Thank you very much Sander and have a wonderful day!

  • Profile Image
    KOBSDE4
    Answered on March 25, 2019 at 10:22 AM

    Hi,

    This problem persists, also in Samsung browser.

    We have +/- 500 technicians who need to use this forms so it would be useful if this got solved. Only a minority have also Chrome on their smartphone to complete the survey.

    Br,

    Sander

  • Profile Image
    Victoria_K
    Answered on March 25, 2019 at 11:29 AM

    Hello Sander, It could be possible that issue is caused by custom CSS style applied by the form theme used. Please add the following CSS code to your forms to resolve the problem.

    Related guide: How-to-Inject-Custom-CSS-Codes

    .language-dd {

      display: block !important;


    }

  • Profile Image
    KOBSDE4
    Answered on March 26, 2019 at 07:57 AM

    Hi, I tried this but things look even more complicated now.

    https://form.jotformeu.com/82103548597362

    Chrome : OK
    IE : Only some parts get translated : very confusing.


    https://eu.jotform.com/82101773597360

    Chrome : language button appears, but doesn't do anything.
    IE : language button appears, but doesn't do anything.


    We are in the last week of our survey and I get a lot of questions on this. Should I undo the CSS script our can anyone help me further to get this right? Thank you

  • Profile Image
    Victoria_K
    Answered on March 26, 2019 at 09:26 AM

    I see that forms have only language added, but are not translated. Please note that manual translation is required for some languages. That is why language selector does nothing for the forms.

    Please follow our guide to complete the translation and then check again how it works:

    How-to-Make-Your-Forms-Multilingual

  • Profile Image
    beril
    Answered on May 22, 2019 at 10:40 AM

    Thank you for reporting the issue. It should be fixed now. Could you please also test it on your side and let us know the result?