Seven submissions, but cannot see the actual submissions

  • Profile Image
    bssrc
    Asked on February 11, 2013 at 08:58 PM

    Someone submitted info into one of my forms this morning.  In the "My Forms" page on your site the additional submission showed up, but when I tried to view it or download the Excel file, nothing is there.  Not even the past submissions.

    I just now noteced that when I try to edit the form on your site the form is completely blank! Help!

    Site where form is located:

    http://www.bssrc.org/17thbssrc/Submit_Poster_Late.html

    I just entered data myself in the form on my website, I received an email (as submitter) and it showed all the data I entered.  Went to JotForm and it showed that there iwas a new submission, when I tried to view it: Blank.

  • Profile Image
    jeanettebmz
    Answered on February 11, 2013 at 10:14 PM

    Viewing blank forms is an issue that has already been reported . Our developers are currently working to fix it. We appreciate your patience on this

  • Profile Image
    bssrc
    Answered on February 14, 2013 at 09:23 AM
    I see from the forum that some sites are fixed. Mine still not working
    Sent from my iPad2
  • Profile Image
    jonathan
    Answered on February 14, 2013 at 11:57 AM

    @ bssrc

    Hi, can you please confirm if you also recieved the email notification of the past submissions?

    I also cannot see submissions on my end.

    Thanks.

  • Profile Image
    jonathan
    Answered on February 14, 2013 at 12:03 PM

    @bssrc

    Hi, I noticed though when I checked that your form in the My Forms is empty..

    Can you please confirm if you are using the form's source code in embedding your form to your website?

    Thanks.

  • Profile Image
    bssrc
    Answered on February 19, 2013 at 04:46 AM
    Sorry for the delay, I have been out of town. When I embedded the form into my website I used the iWeb code option (my site is done in Apple's iWeb). It worked perfectly for months and I was able to get to the submissions. In fact the form is still working on my site. However, when I try to get the submission from JotForm, the form is blank and although the icon for this particular form shows that there are 2 new submissions (out of 10 total), I am not able to view the submissions. The page is just blank. I checked some of my other forms and the submissions are working just fine.
    Bottom line is that I can go to my website, see the form and enter data, and submit, but when I want to look at the submission on the jotform site there is no form or no submission (even though jotform says they are there. Clear?
  • Profile Image
    EduardoMendez
    Answered on February 19, 2013 at 07:52 AM

    Hi there, 

    I have checked the form in question and it appears that the form is empty.  

    The form does not show any fields, as if they have all been deleted:

    It may be that the live embedded version uses the source code of the form when it had fields on it. So it still shows the fields, but they have been deleted on the actual form.

    Have you tried to edit this form? When you do, can you see any fields?

  • Profile Image
    bssrc
    Answered on February 19, 2013 at 08:10 AM
    I believe that is part of the problem. However, I did not delete the form. It was just gone when I went to retrieve a submission. As I said, it was used successfully before. Is there a way to restore the form from the HTML snippet that I inserted into my website (which is still working)?
  • Profile Image
    jonathan
    Answered on February 19, 2013 at 09:55 AM

    @bssrc

    Hi, I am sorry to tell you, but when a field is deleted on the form, it automatically will delete the data in the submissions page that is associated to that field.

    Like in the case of your form...  this form is empty of fields -- which is highly possible they are deleted. Thus, all submission data are also gone.

    When the form's source code was used, it becomes disconnected  on the actual form. This is the reason you can see the form still intact in your live page. But the form in your live page is no longer the form in your My Forms page.

    I cannot find the means to re-create the form in your My Forms page using the form in you live page. You cannot clone back the html form.

    I understand this form is quite a large form, and will be tedius to create again manually, but I think this is the only option left for now.

    I like to emphasize that re-creating the form, even if 100% similar.. will not bring back the lost data (10 submissions)

     

    Thanks.

  • Profile Image
    bssrc
    Answered on February 19, 2013 at 10:00 AM
    Thank you for the response. I think you all should be looking into why the fields were deleted in the first place. It apparently happened on your end, as I read of many people having the same problem recently in the support forum.
  • Profile Image
    jonathan
    Answered on February 19, 2013 at 10:13 AM

    Hi,

    I also agree on your suggestion that the deletion of the field is the main focus of 'why' or 'how'.

    I just cannot confirm to you at this time if this happen on JotForm's end though (for lack of detailed info on my end).

    I will then elevate this to our next level support for proper investigation. The next level support can check further on the backroom for the cause of the fields deletion on this form.

    You will be informed immediately when there is an update on this thread/issue.

    Thanks.

  • Profile Image
    aytekin
    Answered on February 19, 2013 at 11:27 AM

    It is not possible to recover your deleted question labels but the answers were still available. So adding empty questions made it possible to see the answers on submissions page. 

    In the future, you can use the clone feature to make backup copies of your forms.