Card Forms: Ability to turn off the auto-next feature.

  • Profile Image
    gmmobil
    Asked on April 03, 2019 at 03:21 PM

    I am scanning in data into my short text fields using a barcode scanner. Only a portion of the number that is scanned is showing up. Google Forms & Microsoft Forms inputs the scanned data correctly

  • Profile Image
    Kevin_G
    Answered on April 03, 2019 at 05:14 PM

    How are you filling the field? 

    I assume you're using an app to decode the bar code and insert the string on your field. If the string is too long then that may be causing the issue, you may try with a long text entry instead and see if that helps. 

    You may also provide us some examples about it, for example, how the field is capturing the data and how it's supposed to be inserted. 


  • Profile Image
    Kevin_G
    Answered on April 04, 2019 at 03:58 PM

    I watched the video you provided and noticed what you're referring to, now, in order to test if the auto-next feature is causing this, I would recommend you to test with a classic form and see if that helps. 

    Check this guide to create a form under the classic layout: https://www.jotform.com/help/493-How-to-Change-the-Form-Layout 

    Let us know how it goes. 

  • Profile Image
    gmmobil
    Answered on April 04, 2019 at 06:39 PM

    The classic form worked fine, all the barcodes were scanned correctly. So I guess it is the auto-next feature.

    Can you increase the time it takes to transition to the next page after the data is entered? That should resolve this issue.


  • Profile Image
    Kevin_G
    Answered on April 04, 2019 at 07:52 PM

    Ok thanks for testing, I will submit a feature request to either increase the time or turn off the feature for card forms, although we cannot provide an ETA or ensure this will be implemented, we will keep you updated via this thread. 


  • Profile Image
    gmmobil
    Answered on April 19, 2019 at 04:03 PM

    Any update on increasing the time on the auto-next feature? This is stopping us from being able to implement our form.

    It doesn't seem like it's a big deal, 100ms delay should be enough to stop this from happening

  • Profile Image
    gerardw
    Answered on April 19, 2019 at 04:15 PM

    I am sorry but we haven't received an update on the request forwarded to our backend team. We will inform you as soon as we received an update.