Cards forms > Encrypted data > Prepopulate Date field: When data passed from one form to another date field not filled.

  • Profile Image
    Shane
    Asked on April 04, 2019 at 10:52 AM

    Hi, When the form is not encrypted the response in the inbox is formatted correctly and all of the inputted information is there. When I encrypt the form for some reason some of the information goes missing that was inputted, specifically the part about how long at the home address. The form I am referring to is a three part and starts with https://form.jotform.com/90864636468269 . See attached screenshots.

  • Profile Image
    ashwin_d
    Answered on April 04, 2019 at 12:34 PM

    I am sorry for the trouble caused to you. Do you mean to say that "How long at Current Address" is not being displayed in submission when you decrypt?

    Is the issue happening with only one submission or all submissions of part 2 form? Since you have form in 3 parts in 3 different form, how you are combining the submission data as you have shared in the screenshot above?

    Do get back to us on this and we will take a look.

    We will wait for your response.

  • Profile Image
    norlanchrysler
    Answered on April 04, 2019 at 01:43 PM
    Correct, not seeing “How long at current address” on the encrypted results but if I leave the form unencrypted then it is there. (screenshot below, encrypted form result on the left)


    Thanks,
    Shane.

    *****CLICK HERE TO GET PRE-APPROVED ON A VEHICLE*****


    website | vCard | map | email




    Internet Sales Manager
    Nor-Lan Chrysler
    12517 100 St. | Grande Prairie, Alberta T8V 4H2 | Canada
    tel (780) 539-5200 | Text (587) 343-3807 | fax (780) 532-5540


    Confidentiality Note: This e-mail and any attachments are confidential and may be protected by legal privilege. If you are not the intended recipient, be aware that any disclosure, copying, distribution or use of this e-mail or any attachment is prohibited. If you have received this e-mail in error, please notify me immediately by returning it and delete this copy from your system. Thank you for your cooperation.



    WHY BUY FROM NOR-LAN? (click for video)

    To unsubscribe click here.

    ...
  • Profile Image
    david
    Answered on April 04, 2019 at 03:19 PM

    Is the form data being viewed via the submission view?

    https://www.jotform.com/help/269-How-to-View-Form-Submissions

    I tested a clone of the form and even when the data was encrypted the full set of data was shown:

    1554405544Capture.PNG

  • Profile Image
    norlanchrysler
    Answered on April 04, 2019 at 03:43 PM
    Yes, I have the same data missing in either view whether I click from the email or look at it in the inbox portal of your site. The example you are showing is from part 2 of the 3 part process though, what result are you getting on part 3? That is where the information is missing for me when it is encrypted but fine when it is not..

    Thanks,
    Shane.

    *****CLICK HERE TO GET PRE-APPROVED ON A VEHICLE*****


    website | vCard | map | email




    Internet Sales Manager
    Nor-Lan Chrysler
    12517 100 St. | Grande Prairie, Alberta T8V 4H2 | Canada
    tel (780) 539-5200 | Text (587) 343-3807 | fax (780) 532-5540


    Confidentiality Note: This e-mail and any attachments are confidential and may be protected by legal privilege. If you are not the intended recipient, be aware that any disclosure, copying, distribution or use of this e-mail or any attachment is prohibited. If you have received this e-mail in error, please notify me immediately by returning it and delete this copy from your system. Thank you for your cooperation.



    WHY BUY FROM NOR-LAN? (click for video)

    To unsubscribe click here.

    ...
  • Profile Image
    Alan_D
    Answered on April 04, 2019 at 06:22 PM

    I reviewed your form. As you mentioned, some data is not transferred to the other form if the form is encrypted. This is because the encrypted data consists of letters and numbers. For example, when you fill the field "How long at Current Address" as 1 and 1, the first value can be encoded as
    YAU1FcNHb7K9omzGIOjGIlPkfXdFHf34HIUnvMqqKv3nBSOhzDrJ6/9cPxKHPoVwEzXjM6mR6iwtAaZah+LxlBKun4TO/S16PUXYPuT1KnnGG3oieQz2il6FRbMVxEBs3wH/Xx0fPh9GqdKUeqc5x3EjoO4AXSKRHDqXJACtkNhLOTi2yRMRlTXsHF1z3/wYFNZJ0/CiQySiAz88c9QIhuyPCHpDDsH9j62UQ2uvc2W1mllS5Cdfoarc79qIhFgbTzcQhhh3LJtaDU/8atW5xFGSP2osHqTpv8FXJgSlkK+Oh694EBHgjhvp6V7OV28+njnrFhiEUF9YqqsGryuRzg==
    and the second one as
    PqNxnxl9COiyoShk6pKmp4IDruALhwGaAwYT0pR1Wms0Daeh6zIYv4ZaV/3ZT9l2M2WntEEQFT0ySpQh3MFjz68qjKlto0m8TrLpG2UNSPYW6zYjubwgNLZetvSSEfEgpkP+ofSAVPe0toT+sPUUoyf8sTTZ9oiBQ9hFsLViDWcS9HYD4tFbmk2I84NxPPywbSltu+gxYTqUaxXfOQFZk2N0JoGjmhaXBDm6bvA5FGVna6owctgqbECXvKI2yywVlEUnMEDH4HdBVHhsEIu0iqDcswF5rPuImptzKWsLVwnCS1iBsnMnKQWd0CDFOqe3OohuJys3+XdeI/2T9DKq0A==15544162491.png
    Your "How long at Current Address" field is the number field.15544163262.png For this reason, encrypted data (that is, data consisting of letters and numbers) cannot be transferred to the other form. Actually, it is being transferred but the target field does not accept it because it is a number field.

    Please specify the fields to be transferred as text fields. This will require that you re-create the redirecting URL.
    15544165023.png

  • Profile Image
    norlanchrysler
    Answered on April 04, 2019 at 07:43 PM
    Ok, I just switched those two numeric boxes to text boxes as you suggested and edited the forwarding line to the new fields and the problem still exists.

    Thanks,
    Shane.

    *****CLICK HERE TO GET PRE-APPROVED ON A VEHICLE*****


    website | vCard | map | email




    Internet Sales Manager
    Nor-Lan Chrysler
    12517 100 St. | Grande Prairie, Alberta T8V 4H2 | Canada
    tel (780) 539-5200 | Text (587) 343-3807 | fax (780) 532-5540


    Confidentiality Note: This e-mail and any attachments are confidential and may be protected by legal privilege. If you are not the intended recipient, be aware that any disclosure, copying, distribution or use of this e-mail or any attachment is prohibited. If you have received this e-mail in error, please notify me immediately by returning it and delete this copy from your system. Thank you for your cooperation.



    WHY BUY FROM NOR-LAN? (click for video)

    To unsubscribe click here.

    ...
  • Profile Image
    Jed_C
    Answered on April 04, 2019 at 10:05 PM

    I cloned your form and set the encryption to "Yes", but I'm not able to replicate the issue on my end.

    You will see in my screencast below that all fields are shown including the field that you are reporting to be missing when encryption is enabled.

    1554429857enc_form.gif

    Can you please try making a new cloned version of your form and test it so we can isolate the issue?

    Looking forward for your response. 

  • Profile Image
    norlanchrysler
    Answered on April 05, 2019 at 10:43 AM
    I found the problem that I missed after changing it from a number box to a text box and it works for me now. (small mistake in the carry forward field ID to the next form) The problem that we have created now though is my hide a field statement in the form settings for that is broken, it no longer has an option of “> than” in the selection. I needed this because I used it to hide the previous address info boxes if they have been at their current residence for a minimum of 2 years or 24 months. How do we fix that now?

    Thanks,
    Shane.

    *****CLICK HERE TO GET PRE-APPROVED ON A VEHICLE*****


    website | vCard | map | email




    Internet Sales Manager
    Nor-Lan Chrysler
    12517 100 St. | Grande Prairie, Alberta T8V 4H2 | Canada
    tel (780) 539-5200 | Text (587) 343-3807 | fax (780) 532-5540


    Confidentiality Note: This e-mail and any attachments are confidential and may be protected by legal privilege. If you are not the intended recipient, be aware that any disclosure, copying, distribution or use of this e-mail or any attachment is prohibited. If you have received this e-mail in error, please notify me immediately by returning it and delete this copy from your system. Thank you for your cooperation.



    WHY BUY FROM NOR-LAN? (click for video)

    To unsubscribe click here.

    ...
  • Profile Image
    david
    Answered on April 05, 2019 at 12:00 PM

    The Greater/Less than conditions are only available for use with number fields and calculation widgets.  You could pass the value conditionally to a number field or use a calculation widget to capture the value, then base the conditions off that field.

  • Profile Image
    norlanchrysler
    Answered on April 05, 2019 at 01:43 PM
    Ok, I just tried to add a calculation widget as per your suggestion, but it is not showing my “How long at Current Address” field as an option for some reason. (screenshot below)


    Thanks,
    Shane.

    *****CLICK HERE TO GET PRE-APPROVED ON A VEHICLE*****


    website | vCard | map | email




    Internet Sales Manager
    Nor-Lan Chrysler
    12517 100 St. | Grande Prairie, Alberta T8V 4H2 | Canada
    tel (780) 539-5200 | Text (587) 343-3807 | fax (780) 532-5540


    Confidentiality Note: This e-mail and any attachments are confidential and may be protected by legal privilege. If you are not the intended recipient, be aware that any disclosure, copying, distribution or use of this e-mail or any attachment is prohibited. If you have received this e-mail in error, please notify me immediately by returning it and delete this copy from your system. Thank you for your cooperation.



    WHY BUY FROM NOR-LAN? (click for video)

    To unsubscribe click here.

    ...
  • Profile Image
    ashwin_d
    Answered on April 05, 2019 at 02:29 PM

    Unfortunately we are unable to see the screenshot you have shared. I did check your form and you have added form calculation widget for question "Calculation for Length of Time at Current Address". If you add condition in form, you should be able to see the option greater than / less than option. Please check the screenshot below:

    1554488837greaterThan.gif

    I would suggest you to please share a screenshot of the issue and we will take a look. The following guide should help you how to upload image in forum post:   https://www.jotform.com/help/438-How-to-Post-Screenshots-to-Our-Support-Forum 

    We will wait for your response.

  • Profile Image
    norlanchrysler
    Answered on April 05, 2019 at 04:38 PM

     As you can see in the picture below, selecting the field of "How Long at Current Address" is missing from the Calculate widget. Why is that? What can I do about it?1554496683JotForm Calculation Widget Iss

  • Profile Image
    Alan_D
    Answered on April 05, 2019 at 06:40 PM

    Let's go a little back and try to solve the problem.
    Define "How Long at Current Address" field as numeric and month only(in part 2).15545024321.png And create a condition that depends on it.15545024522.png The first problem will be solved. Now we'll pass the data in this field to the third part. In the third part, the area corresponding to this area will be referred to as the short text input field. In this way, we will be able to transfer the encrypted value to the third form. This is part 3.
    15545036683.pngNow setting our new link. This is a part of "part 2's redirection link". We must pass the value like that.

    &howLong17={howLong2:field_1}

    How Long at Current Address in part 2
    How Long at Current Address Text Field in part 3
    This is my test
    155450397140.png
    15545038904.png

    Hope it helps.

  • Profile Image
    david
    Answered on April 08, 2019 at 12:17 PM

    It would be target field = current field ID.  So if the field in form 3 is being targeted, it would be form3field = form2field since you are making the field in form 3 equal to the field in form 2.

  • Profile Image
    Shane
    Answered on April 08, 2019 at 01:52 PM

    My bad, the weekend obviously screwed with my head. I have that working now as you laid out. My only problem now is I changed date of birth widgets because I did not really like the last one and now that field is not working when encrypted but works fine when not encrypted. (see attached screen shot) I also tried it with using a short text box as well on the third part like we did on the length of time at current address issue and that does not fix it.1554745922JotForm Results Encrypted DOB

  • Profile Image
    ashwin_d
    Answered on April 08, 2019 at 02:33 PM

    I am sorry for the trouble caused to you. I did test this in one of my own form and the date field works as expected in encrypted form. It displays the selected date correctly. Are you pre-populating the date field with URL parameter and is the issue happening in Application  Part 3?

    I did check the URL parameter you have added in thank you URL and you seems to be using the following parameter:

    dateOf21={dateOf}&dateOf={dateOf}

    Here is the correct field name which you need to use in URL parameter. If the field name of your date field is "date" the correct parameter should be:

    date[month]={date:month}&date[day]={date:day}&date[year]={date:year}

    Please edit the URL parameter in your form and see if that solves your problem.

  • Profile Image
    norlanchrysler
    Answered on April 08, 2019 at 02:49 PM

    But my field name shows as dateOf in the config section of Form Part 2. (screenshot below) Would I not use that then? I tried it with your format from the previous message and it did not work. I also tried it with your format but using dateOf and that did not work either.

    1554749350JotForm Results Encrypted DOB

  • Profile Image
    Nik_C
    Answered on April 08, 2019 at 04:43 PM

    Could you please try with this instead:

    dateOf[month]={dateOf:month}& dateOf[day]={dateOf:day}& dateOf[year]={dateOf:year}

    Let us know if that works for you.

    Thank you!

  • Profile Image
    norlanchrysler
    Answered on April 08, 2019 at 04:49 PM

    Ok, I tried that and it still just shows the month only. (see screenshot below)

    1554756566JotForm Results Encrypted DOB

  • Profile Image
    norlanchrysler
    Answered on April 08, 2019 at 04:53 PM

    Hold on, it shows up fine in the email link but not in the inbox in the jotform backend. See screenshot below of the email link.1554756806JotForm Results Encrypted DOB

  • Profile Image
    Kevin_G
    Answered on April 08, 2019 at 08:09 PM

    I have been testing this feature and I have noticed that the date decrypts properly.

    Unfortunately for that field you cannot change the date format. 

  • Profile Image
    norlanchrysler
    Answered on April 09, 2019 at 10:03 AM

    I think you may have misunderstood what I was saying. The DOB field works now when encrypted but for some reason it is only showing correctly when you click on the email that it sends you once the form has been filled out but if I go into the inbox of the 3rd part of that form in the JotForm backend then it only shows the month and not the day or year. Do you know what I mean? (Screenshots in previous posts right above this.)

  • Profile Image
    Alan_D
    Answered on April 09, 2019 at 12:06 PM

    I have cloned and tested your form. I wasn't able to reproduce the same issue. The DOB field appeared correctly in submissions page.
    The email content.
    15548258562.pngThe submissions page.
    15548258971.pngCan you please try it again and inform us?
    Did you mean submission page by "JotForm backend"?

  • Profile Image
    norlanchrysler
    Answered on April 09, 2019 at 05:43 PM

    No, the submissions section work fine. I am referring to the inbox in the myforms section of your site. I just tried it again and it didn't work. (screenshot below) Maybe I am just going to the wrong place to view it.

    1554846159JotForm Results Encrypted DOB

  • Profile Image
    Jed_C
    Answered on April 09, 2019 at 06:54 PM

    Please give me some time to test this and I'll get back to you as soon as possible. Thanks.

  • Profile Image
    Jed_C
    Answered on April 09, 2019 at 07:51 PM

    My observation is that you are using a Birth Date widget which is not passed into the field but is shown in the URL.

    Sample of your clone form.

    1554853499date_field.png

    However, date of birth field is shown on my end when viewing my inbox. 

    1554853632My Forms _ JotForm - Google Ch

    Have you tried using a regular date picker element and see if it will show an incomplete date? Can you please try that for testing purposes only?

    1554853831The Easiest Online Form Builde

    NOTE: Tested this with a clone of finance application part 3 encrypted enabled.

    Looking forward for your response. 

  • Profile Image
    norlanchrysler
    Answered on April 10, 2019 at 10:25 AM

    Ok, I setup the date picker you suggested and called it "Date of Birth Test". It is not passing the info on either the emailed form or the inbox form. (screenshot below)

    1554906314JotForm Results Encrypted DOB

  • Profile Image
    ashwin_d
    Answered on April 10, 2019 at 11:42 AM

    I did check your form application part 2 & 3 and you seems to have added the URL parameter correctly:

    dateOf21[month]={dateOf13:month}&dateOf21[day]={dateOf13:day}&dateOf21[year]={dateOf13:year}

    The data should be populated and displayed correctly in submissions. I have sent a test submission in your form. Can you please check and see if the date of birth test is being displayed correctly. If you disable encryption in form, the data is displayed correctly?

    Do get back to us on this and we will escalate it to our backend team.

  • Profile Image
    norlanchrysler
    Answered on April 10, 2019 at 11:57 AM

    Yours showed the same as mine with just letters where the date should be on the inbox form. I took off the encryption and tried it again and that works fine for bot date fields. (screenshot below)

    1554911837JotForm Results Not Encrypted.

  • Profile Image
    Nik_C
    Answered on April 10, 2019 at 02:16 PM

    Thank you for additional information, I will consult my colleagues on this since I wasn't able to replicate that issue on my end.

    We'll get back to you via this thread.

  • Profile Image
    norlanchrysler
    Answered on April 10, 2019 at 02:35 PM

    Ok, thanks.

  • Profile Image
    Nik_C
    Answered on April 12, 2019 at 03:36 AM

    Thank you for your patience.

    I had to do some testing regarding this issue.

    Now, since this is a long thread and to avoid me missing something I will recap, the issue is that date field from form 2 to form 3 is not filling properly when forms are encrypted, correct?

    I was able to replicate that, and the issue is related to the actual encrypted data (as mentioned in one of the replies above).

    For example, this is a name field prepopulated from one form to another:

    15550543972019-04-12_9-32-56.png

    The same applies to other fields involved, date field included. But, date field will work only if a number in format XX/XX/XXXX is passed to it.

    So, for example, my date field (year) should be prepopulated with this: 

    date[year]=I0qLtun9qVVToINTM2et13CGEIwKOFcxFUx/whMk7kkL8+RG8eHlinulfoL9Tf3DsZq0aLEDfiQ7cpZ20vCnqUz/gctjreKlLS3oxDfjSLbNUrmf0hO5PO7Wf/sgmGHtdnYx2NiPPRwXXeWSSNSfqFCWuBf2Gz3SNVOQSmZgwLhoknO79OyRzlnheZ4GiLBXhwPHcGwh9xAk/yM+NENSo8tX80jnBeaU9fT+TX5NApc9fQsn1fzsDVLvMR7Hg4pIqrKTBU1cOCjARAcYuu3SZTBdbLpbVUWKDoQJezS0K6mAB/tsWpsT9MHBZCAUUV+VN5qxd5jJzlhTV55WrIT1Eg==

    And that cannot work.

    I'm not sure if that can be handled somehow on our backend, but I would like to forward to them for further checking.

    Just please confirm first so we can do that.

    Thank you!

  • Profile Image
    norlanchrysler
    Answered on April 12, 2019 at 10:12 AM

    Yes, you are correct. The date field is not passing on to the third form from the second form when it is encrypted. Thanks.

  • Profile Image
    david
    Answered on April 12, 2019 at 11:19 AM

    Thank you for the confirmation.  We will submit a ticket for this and let you know as soon as we have any updates.

  • Profile Image
    norlanchrysler
    Answered on April 12, 2019 at 11:50 AM

    Ok, thank-you.

  • Profile Image
    Nik_C
    Answered on April 12, 2019 at 12:39 PM

    I escalated this to our backend team for further checking.

    We'll keep you posted via this thread.

    Thank you!

  • Profile Image
    norlanchrysler
    Answered on April 12, 2019 at 01:17 PM

    Ok, thank you.

  • Profile Image
    norlanchrysler
    Answered on April 12, 2019 at 04:40 PM

    Not sure if it is related, but I just added an "image choice" box to my form part 1 that gets forwarded to form 2 and then to form 3 and it also is not carrying the information forwarded.

  • Profile Image
    Kevin_G
    Answered on April 12, 2019 at 06:35 PM

    May you provide more details about the issue? 

    Are you passing the data through the form URL? 

    If so, note that this will not work for encrypted forms. 

  • Profile Image
    norlanchrysler
    Answered on April 12, 2019 at 06:41 PM

    Yes, I am passing the data through the form url. I am having multiple issues trying to get my fields working with encryption. Do you have a list of which form elements and widgets will and won't work with encryption then?

  • Profile Image
    Jed_C
    Answered on April 12, 2019 at 08:12 PM

    You can use the prepopulate app in this link https://prepopulate.jotform.io/ to check if the widget allows to receive as prepopulated data.

    I checked the image choices widget and it is not showing, that means passing a value using that widget will not work. Try using that tool when checking out a widget / element.

  • Profile Image
    Kevin_G
    Answered on April 15, 2019 at 04:20 PM

    For encrypted forms autoresponders are not sent, they only work with non-encrypted forms. 


  • Profile Image
    Jed_C
    Answered on April 15, 2019 at 06:32 PM

    Your limits has been reset per your request.  Let us know if you have any questions or if you need further assistance.