Submit button not working

  • Profile Image
    Wayne_CCF
    Asked on April 04, 2019 at 06:38 PM

    We have 3 Jotforms embedded on our website.  The SUBMIT button does not work on any of them.

    At first we thought the problem might be that we had used embed code vs I-frame code, as described here.   https://www.jotform.com/help/148-Getting-the-Form-iFrame-Code

    However, when we tested the forms directly from the Jotform link (i.e., not embedded), the Submit button still didn't work.  When clicked on, the button jumps horizontally to the right, but does not otherwise do anything.  Note:   we had previously had to customize the CSS code because the button was not aligned properly.  We had followed the instructions from this posting:  https://www.jotform.com/answers/1130823-How-to-align-the-Submit-button-in-the-form.  That solved the alignment problem, but I'm wondering if it has now caused this inaction problem.

    The 3 forms in Jotform, with their corresponding embedded versions:

    https://form.jotform.com/90658617031154 http://www.carlisletrailsday.org/Lead-a-Walk-22.html

    https://form.jotform.com/90658247142156   http://www.carlisletrailsday.org/Solo-Walk-23.html

    https://form.jotform.com/90656975856174     http://www.carlisletrailsday.org/Join-a-Walk-21.html






  • Profile Image
    jherwin
    Answered on April 04, 2019 at 09:05 PM

    I test submitted the three forms using stand-alone form and it all goes through. Can you please check if it's still not working on your end? If yes, try to reset your network or change the IP address of the network you're using and clear your browser cache.

    Give it a try and let us know how it goes.

  • Profile Image
    broomehippodrome
    Answered on April 04, 2019 at 09:32 PM

    I'm having the same issue.  Customers are saying its going to a blank gray box after they hit submit. 


  • Profile Image
    Wayne_CCF
    Answered on April 04, 2019 at 10:08 PM

    Thanks Jherwin.  Subsequent to my posting, I found this prior email thread and applied the suggested fix. It worked.


    https://www.jotform.com/answers/1273114-Submit-button-is-not-working  

  • Profile Image
    Kiran
    Answered on April 04, 2019 at 11:21 PM

    @broomehippodrome,

    We request you to open a new thread with the web page URL where the form is embedded so that one of our support team members can assist you further.

    @Wayne_CCF,

    Glad to see that the issue is now resolved for you. Please do not hesitate to get back to us if you need any further assistance. We will be happy to help. 

    Thank you for using JotForm!