Auto send emails arent sending

  • Profile Image
    StAnns
    Asked on April 04, 2019 at 09:08 PM

    My auto responder emails arent sending and I have not been able to figure out why. Also, is there a way to re-send the ones for forms that have already been submitted but didnt receive the confirmation emails?

  • Profile Image
    BDAVID
    Answered on April 04, 2019 at 10:43 PM

    Unfortunately, there is no way to automatically resend the ones that were not sent. I have checked your autoresponders, and they appear to be set up correctly, can we do a real submission in order to test them?

  • Profile Image
    StAnns
    Answered on April 04, 2019 at 11:43 PM
    Yes! Feel free to do a real submission.
    Thank you for your help!
    ...
  • Profile Image
    Mike_G
    Answered on April 05, 2019 at 02:40 AM

    I have checked your form and I see that the Email Autoresponders you have created in your form are set to be sent conditionally.

    1554445169t02_17_17.png

    Based on the condition that is associated with the email autoresponders in your form,

    1554445310t02_21_21.png

    the email autoresponders are sent to the email address entered in a field that has {email} as its field name or {uniqueID} — How-to-Find-Field-IDs-and-Names

    I can confirm that the email autoresponders and conditions are set up properly, however, the {uniqueID} of the Email Correctness widget you used to collect the email address of your respondents is not {email}, but {email127}.

    1554446215t02_30_04.png

    You can update the one in the condition or you can also edit the one in the widget's properties to have a matching {uniqueID}.


    That should fix the issue you are having. Otherwise, please feel free to let us know.