Airtable: attachments not sending to Airtable.

  • Profile Image
    startuphealth
    Asked on April 09, 2019 at 03:08 PM
    In the meantime, can you please help me figure out why the attachments are not being sent through to Airtable from JotForm via Zapier, per my first question in this thread? I have been in contact with Zapier and they directed me to you since this is a JotForm issue.

    Please let me know ASAP.

  • Profile Image
    Kevin_G
    Answered on April 09, 2019 at 04:06 PM

    I have been testing the Zapier integration and I can see the files are transferring properly on my end, I have cloned your form and this is what I see: 

    1. JotForm submission: 

    1554840142screenshot_01.png

    2. Zapier response: 

    1554840310screenshot_02.png

    3. Record on Airtable: 

    1554840339screenshot_03.png

    May you please let us know how are you receiving the data on your end? 

    You may upload screenshots to this thread, this guide will help you uploading the images here: How to Post Screenshots to Our Support Forum 

    Note that attached images via email replies will not reach this thread. 

  • Profile Image
    startuphealth
    Answered on April 09, 2019 at 05:58 PM

    This is what the data looks like on my end:


    1. JotForm submission - uploaded a test document:

    1554847009Screen Shot 2019-04-09 at 5.52


    2. Zapier response (from task history in the zap) - it says the zap went through successfully with no errors - below is the field corresponding to the JotForm submission above:

    1554847037Screen Shot 2019-04-09 at 5.54


    3. Record in Airtable (blank):

    1554847085Screen Shot 2019-04-09 at 5.55

  • Profile Image
    denis_calin
    Answered on April 09, 2019 at 07:22 PM

    Hi @startuphealth

    Can you please try setting the upload fields to disallow multiple file attachments and then check if attachments are showing up in Airtable?

    1554852083Screen Shot 2019-04-09 at 4.17


    Thank you very much, we will be waiting for your response! 

  • Profile Image
    startuphealth
    Answered on April 10, 2019 at 10:46 AM

    Hi Denis, I limited the number of files for each field with attachments to 1, and tried testing again with a new form entry. Unfortunately every other field in the JotForm is still getting through to Airtable except for the attachments - I'm still seeing blank fields in Airtable where documents should be. 

  • Profile Image
    BDAVID
    Answered on April 10, 2019 at 12:33 PM

    I understand that you are trying to accomplish this through Zapier. I have also tested through our own integration we have with Airtable: https://www.jotform.com/help/561-How-to-integrate-JotForm-with-Airtable

    But the file was not sent even though the file type was created in Airtable, and the fields were matched correctly:

    AirTable Field:

    1554913782attachment.png

    Matched:

    1554913859attachment_001.png

    I will report this to our back-end team to check further why the upload field will not transfer. You will be updated via this thread.

  • Profile Image
    onurince
    Answered on April 11, 2019 at 02:54 AM

    Hi,

    If "Require log-in to view uploaded files." is checked in your account settings, Airtable could not fetch your attachments. 

    To send your uploaded files to Airtable, please kindly go to your account settings page then go to Settings section and uncheck the "Require log-in to view uploaded files." option.

    Please check the screenshot below:

    1554965322Screen Shot 2019-04-11 at 09.4

    Please let us know how it goes.

    Thanks.

  • Profile Image
    startuphealth
    Answered on April 11, 2019 at 11:22 AM

    This worked! Thanks for your help