Image Picker Widget: Images are loading very slowly.

  • Profile Image
    ylenia.pratico
    Asked on April 10, 2019 at 05:18 AM

    Hello, 

    the images on my Image Picker multi-choice do not show, unless the user lets the page load for a very, very long time. 

    I tried to upload my pictures directly on your server and to reduce their size, but neither of those solutions solved the problem. Users keep seeing only an endless loading icon.

    How can I solve this issue?

    Thanks,
    Ylenia

    Screenshot
  • Profile Image
    betty
    Answered on April 10, 2019 at 10:01 AM

    I am looking into this. I will inform you as soon as possible.

  • Profile Image
    betty
    Answered on April 10, 2019 at 10:41 AM

    I was able to replicate this issue on my end. I decided to escalate this issue to our development team. You will be notified as soon as this issue is resolved.

  • Profile Image
    hayk
    Answered on April 11, 2019 at 08:29 AM

    Hi Ylenia, I checked your form and I saw the issue. You have used imggmi.com web site for hosting your pictures and the widget has some issues for displaying images from that website. Anyway I have a solution for you. You can use postimages.org web site for hosting all your images for getting direct links for every image. The site is very easy to use and it also allows multiple uploading. I used that web site for hosting some of your images and then I used the direct links in the widget's settings. You can check and see how fast the images are getting shown. Here is my form link: https://form.jotform.com/91002985481963

    Please take a try and let us know if you need any other assistance.

    Regards,
    Widget Team

  • Profile Image
    ylenia.pratico
    Answered on April 11, 2019 at 08:47 AM

    Hi Hayk,
    thank you, your solution worked perfectly.

    Best, 
    Ylenia