What is JotForm?
JotForm is a free online form builder which helps you create online forms without writing a single line of code. No sign-up required.

At JotForm, we want to make sure that you’re getting the online form builder help that you need. Our friendly customer support team is available 24/7.

We believe that if one user has a question, there could be more users who may have the same question. This is why many of our support forum threads are public and available to be searched and viewed. If you’d like help immediately, feel free to search for a similar question, or submit your question or concern.


  • Profile Image

    My form don't work when i paste the code in my website.

    Asked by seege on February 13, 2013 at 11:05 AM

    please this his below the link to my form. i don't know why but when i use the preview button it's work well, but when i copy the code and paste it to my website its don't work.

     

    please is anything wrong with this?  http://form.myjotform.com/form/30433526816553

    Page URL:
    http://www.allbusinessgabon.com/boutique_madoungou_phone.html

  • Profile Image

    Answered by jefreylandicho on February 13, 2013 at 11:30 AM

    Can you please try to do the following?

    1. Re-embed the form using IFRAME

    2. Clear your browser cache and cookies.

     

    If the problem still persist, please let me know and we can look at the next possible solutions. 

     

  • Profile Image

    Answered by seege on February 13, 2013 at 11:51 AM

    OKAY. i try it

  • Profile Image

    Answered by seege on February 13, 2013 at 11:53 AM

    just to say that with the others display options it's work very well except "lightbox". and it's lightbox option i want to use.

  • Profile Image

    Answered by jefreylandicho on February 13, 2013 at 12:02 PM

    It seems you site is having a script conflict. Can you please try adding 

     

    script type="text/javascript">
    $.noConflict();</script>

     

    under drop down script

    Please check the link below for reference on how to use the script

    http://api.jquery.com/jQuery.noConflict/

  • Profile Image
    JotForm Support

    Answered by abajan on February 13, 2013 at 12:25 PM

    @seege

    There's something very strange about your page's source. I noticed that the JavaScript which is normally bundled with the iFrame version of a form's code is repeated four (4) times, yet there's no iFrame. There's just the lightbox. This screenshot shows the section of your page's source to which I'm referring. I think that if you remove those four scripts and leave the lightbox code, it should work. (Incidentally, I didn't notice any jQuery in the page.)

  • Profile Image
    JotForm Support

    Answered by abajan on February 13, 2013 at 12:33 PM

    Actually, there are also a couple problems I spotted in the lightbox code too. I'll be back.

  • Profile Image

    Answered by seege on February 13, 2013 at 12:36 PM

    "under drop down script" mean  i past this after the code i copied?

  • Profile Image

    Answered by seege on February 13, 2013 at 12:45 PM

    @ABAJAN yes may be it's because i build this form myself and i clone several times the same form to change some field to have this final result. i don't know where to go to remove this repeated scripts please.

  • Profile Image
    JotForm Support

    Answered by abajan on February 13, 2013 at 12:51 PM

    @seege

    After saving your page to my computer, cloning the form and substituting the clone's lightbox code for yours, I was able to get the lightbox to work. There may be no need to remove the repeated scripts. Let me run some further checks and get back to you.

  • Profile Image

    Answered by seege on February 13, 2013 at 12:54 PM

    OKay. maybe it's my website builder editor (i work with webstarts). i'm waiting for your check. thank you.

  • Profile Image

    Answered by seege on February 13, 2013 at 01:29 PM

    okay! it's seem that the problem come from scripts errors in my form. i tried to use another lightbox form and its work perfectly. please how i can remove this errors. it's to long to restart building this form again. please thank you

  • Profile Image
    JotForm Support

    Answered by abajan on February 13, 2013 at 01:32 PM

    Hi again seege,

    Change your lightbox code as shown here. (You'll see the differences if you examine them carefully.) Incidentally, I could be wrong but there appears to be no jQuery on the page and as such, there's no need to use the jQuery noConflict script. It would just be extra code that serves no purpose on the page.

  • Profile Image

    Answered by seege on February 13, 2013 at 02:02 PM

    still not working. i think i have no choice that rebuild this form from blank again :-(  if any helps, but thank you very much.

  • Profile Image
    JotForm Support

    Answered by abajan on February 13, 2013 at 02:09 PM

    Before building a new form, try just cloning the current one and inserting the clone's lightbox code into the page.

  • Profile Image

    Answered by seege on February 13, 2013 at 02:19 PM

    i already clone several times this form but it's the same thing: no action from the link.

  • Profile Image
    JotForm Support

    Answered by abajan on February 13, 2013 at 02:37 PM

    Does the WebStarts editor not allow you to manually edit the lightbox code at all? It's just a couple of changes which are needed to make the current code work. If you compare the two lightbox codes at the link I earlier provided, you'll see that the bottom one has a backslash after the "J" in J'ADORE (J\'ADORE) and the last line has no reference to javascript.

  • Profile Image

    Answered by seege on February 13, 2013 at 02:41 PM

    okay! i will explore it carefully and back to you just after

  • Profile Image

    Answered by seege on February 13, 2013 at 10:08 PM

    i really don't understand. i build another form but still the same error. this time the lightbox appear but don't load the form...

  • Profile Image
    JotForm Support

    Answered by abajan on February 13, 2013 at 10:18 PM

    @seege

    It should be fine now. For some reason which I'm yet to determine, your account was automatically suspended by our system.

    Our apologies for any inconvenience caused.

  • Profile Image

    Answered by seege on February 13, 2013 at 11:10 PM

    okay! i just see that like a miracle the form now  works! i note just that the width of the form don't change. but for now i hope all will be okay this time. thank you

  • Profile Image
    JotForm Support

    Answered by EltonCris on February 13, 2013 at 11:43 PM

    @seege,

    That's nice. Thanks for letting us know about it.

    If there's anything you need assistance with, feel free to message us here. Thanks!