Trello Doesn't Authenticate when Integrated

  • Profile Image
    Solomon Daniels
    Asked on April 12, 2019 at 07:47 AM

    I've tried several times to authorize my account in Trello. Yet every time I go to fill a form, it says I first need to authorize my account. Logged out of both and back in; still no luck. I'm starting with a free Jotform account. Do I need to have a paid account fo integration?

  • Profile Image
    Richie_P
    Answered on April 12, 2019 at 10:36 AM

    You don't need to have a paid subscription to use JotForm's Integrations.

    I have tested the Trello integration using my sample form and I was able to Integrate without any issue.

    Can you please try to disable any pop-up blockers in your web browser?

    Can you please try clearing your browser's cache or use another web browser in editing your form?

    Can you try re-integrating your form with Trello?

    When you click Authenticate in your Integration, make sure you allow JotForm to use your account.

    Looking forward for your response.