Why does my page show up in German?

  • Profile Image
    mgetman
    Asked on April 12, 2019 at 10:09 AM

    I had to hit "translate from German to English"...and then many of the words were changed to gibrish.

    Screenshot
  • Profile Image
    Kiran
    Answered on April 12, 2019 at 12:04 PM

    I have checked your last edited form and see that it is displaying in English only. Could you provide us with more information on the issue that you are referring to and the link to the form so that we can assist you further.

    Thanks!

  • Profile Image
    mgetman
    Answered on April 12, 2019 at 12:43 PM
    I included a screen shot which clearly show german titles on my page. The forms themselves remained in English. When I went in to look at individual responses, I saw that the names had been translated from German to English…Susan Liebgott became Susan Love God….very strange.
    Here are more screenshots…look at #88 with the translate link at the top.
    ...
  • Profile Image
    Welvin
    Answered on April 12, 2019 at 02:18 PM

    Our sincere apologies for what happened. 

    This support forum does not support inline image attachment. You will have to access this thread by following the guide below to upload a screenshot.

    https://www.jotform.com/help/438-How-to-Post-Screenshots-to-Our-Support-Forum

    As for the translation, it's a bit strange, but I got assigned to a similar thread a while ago. The issue is already fixed for the user, but if the issue persists to your end, please do the following:

    1. Close Jotform from your browser.

    2. Clear your browser cookies for Jotform, guides below:

    https://support.mozilla.org/en-US/kb/delete-cookies-remove-info-websites-stored 

    https://support.google.com/chrome/answer/95647?hl=en 

    3. Log in again to see if the problem is fixed. If not, please update us here so we can investigate further. 

    I'd also suggest checking your language settings in the account. Go to Settings page here https://www.jotform.com/myaccount/settings

  • Profile Image
    mgetman
    Answered on April 12, 2019 at 02:43 PM
    Thank you. Clearing the cookies seemed to do it.
    ...