My form is not syncing contacts to Salesforce

  • Profile Image
    paxchristipax
    Asked on April 12, 2019 at 08:09 PM

    Was finally able to get my first form to push to Salesforce. 

     

    I created another one and now that one is not pushing to Salesforce. Fields are mapped correctly. 

     

    I require some assistance. Using Jotform for a client. Thanks!

  • Profile Image
    jherwin
    Answered on April 12, 2019 at 10:41 PM

    Could you please try the following and see if it will fix the issue:

    1.) Disconnect the form in your salesforce
    2.) Clear form cache: How-to-Clear-Your-Form-Cache
    3.) Close your browser and open it again
    4.) Re-Integrate the form in SalesForce

    Please give it a try and let us know how it goes.

  • Profile Image
    paxchristipax
    Answered on April 12, 2019 at 10:57 PM

    Nothing different

  • Profile Image
    paxchristipax
    Answered on April 12, 2019 at 11:28 PM

    Cleared and reintegrated and now It will create a contact but none of the fields push. 


    I dont get how Jotform can be so inconsistent. Blowing my mind.

  • Profile Image
    Jed_C
    Answered on April 13, 2019 at 03:59 AM

    I cloned your form and integrated it with my Salesforce account, the name and email was pushed and contact was created.

    1555142152contact_SF.png

    1555142213contact_SF2.png

    Here's how my integration looks like:

    1555142263The Easiest Online Form Builde

    Looking forward for your response. 

  • Profile Image
    paxchristipax
    Answered on April 13, 2019 at 12:33 PM

    I've done the same thing three times now and it pushed this time. But I've noticed that it only pushes after I involve a Jotform rep. It's pretty bizarre. Whatever you did, thanks. 

  • Profile Image
    Welvin
    Answered on April 13, 2019 at 02:06 PM

    There is no option for us to just stop or push submissions manually. If you are testing the form to your end, make sure that your name and email is not yet on the list. Otherwise, that will just update everything, not add a new record to your Salesforce list/contact. 

    Also, make sure that field options, especially from Multiple Choices, Single Choice, and Dropdown are the same from your Salesforce fields. The capitalization, spaces, commas, and etc matters. They should look exactly the same.