Notification/Autoresponder Emails: The subject of the email shows NBSP html tag for the empty fields of the User Contributed Dropdown widget.

  • Profile Image
    diana
    Asked on April 16, 2019 at 08:02 AM

    The user has reported that he receives the subject of Notification and Autoresponder emails as follows:

    1555415188Screen Shot 2019-04-16 at 14.4

    As you can see in the above email content, the subject of the email has "&nbsp" tag.

    I have cloned the user's form and tested the issue on my end.

    1- The user has set Email Subject of the Notification and Autoresponder Emails as follows:

    1555415464Screen Shot 2019-04-16 at 14.4

    2- Then, I have checked those fields. The fields that are shown as "&nbsp" belong to the User Contributed Dropdown widget. 

    1555415542Screen Shot 2019-04-16 at 14.5

    3- If the above fields of the widget are filled, their name is shown on the Email Subject. However, if these fields are not filled then the "&nbsp" is shown in the subject as I have mentioned above.

    4- I have tested this issue on other fields such as phone number, full name, textbox, etc. The issue only occurs on the User Contributed Dropdown widget.

     

    Lastly, I have created a test form on my end.

    - I have added the User Contributed Dropdown widget to the form.

    1555415795Screen Shot 2019-04-16 at 14.5

    - I have set the Notification and Autoresponder Emails. The widget fields are added to the Subject as follows:

     1555415809Screen Shot 2019-04-16 at 14.5

    - I have filled the form without filling the widget. The email subject that I have received from both Notification and Autoresponder Emails are as follows:

    1555415921Screen Shot 2019-04-16 at 14.5

    As a result, the empty fields of the widget weren't shown as "&nbsp" for the Notification/Autoresponder Emails of the Test form.






  • Profile Image
    hayk
    Answered on April 17, 2019 at 02:14 AM

    Hi @diana,
    The user had extra added spaces for the 1st option in every dropdown field. I deleted the extra spaces in the user's form and now it doesn't show any "&nbsp" in the notification E-mail. I cloned the form and did a test submit:
    1555481213Screenshot123.png 

  • Profile Image
    diana
    Answered on April 17, 2019 at 02:24 AM

    Hi @hayk,

    I have noticed that, as well.

    However, I have tested the issue on my test form. As you can see in the below figure, there is an extra space in the dropdown options on my end, too.

    1555482134Screen Shot 2019-04-17 at 09.2


    Although, I don't receive the email subject with the "&nbsp" tag.


    Therefore, the issue on the user's end is persisting.



  • Profile Image
    hayk
    Answered on April 17, 2019 at 02:58 AM

    Please clone the user's form again and test it one more time or test it in incognito (private) mode and You will not get  "&nbsp". The issue on the user's end persists because of the browser's cache. I also cloned your form and I noticed that you don't have any spaces in the 1st option, you have a new line but not spaces. I cloned your form and added spaces and now I am getting "&nbsp" tags in the notification E-mail. Here is my cloned form with spaces, feel free to clone it and test it on your end and you will see the difference: https://form.jotform.com/91061051794959