My form fields are randomly not showing

  • Profile Image
    Muon
    Asked on April 16, 2019 at 12:59 PM

    When I run my form sometimes the Form Field values do not show up. It appears to be random and if I start over and enter the exact same values then they do appear, but then other form fields may not appear.

    This happens for both user input form fields, default form fields, non-hidden and hidden sections, and is not consistent so I would have to call it a 'random' happening. It also happens whether I am using my computer web browser or on my android phone, both using chrome.

    As this is one of your coolest features I hope there is a simple fix to make it more reliable.

    Thanks

  • Profile Image
    Welvin
    Answered on April 16, 2019 at 02:19 PM

    You have three last edited forms. Which of the form is having the issue? Please copy/paste the URL here. I checked this form http://www.jotform.us/form/91055444863157, it is currently disabled. 

    You have a few conditional logic in the form that is set to hide fields. That may be related to the problem. I would suggest checking again and let us know which field should suppose to show based on an input/selection. 

    Note that when setting up a conditional logic, the basic rule would be not to mix up the Show and Hide conditions for the same field. The rule would always to configure the SHOW, not the opposite which is HIDE. The field set to show with the condition will remain hidden in the form until the conditional logic is met. So, for example,

    Show A when 1 is filled - add this.

    Hide A when 1 is not filled - don't add this. 

    I hope that helps. Please let us know if you require additional assistance.