Customer having problems making payments on mobile phones

  • Profile Image
    acefootball
    Asked on April 17, 2019 at 07:38 AM

    Hi Guys,

    Many of my customers have used their mobile phones to complete the Ace Football camp form and make payments. However, they have all said they can input the details but could not complete payment. Payment would be succesful on laptop or dektop. Can you advise please.

    Secondly, several of my customers have refused to pay online because Stripe has appeared as an unsecure site when paying through Jotform. I have contacted Stripe and they assure me they are are secure site and that the issue may lie with yourselves. Can you advise on this too please.

    Regards

    Marshall Phillips

  • Profile Image
    Victoria_K
    Answered on April 17, 2019 at 11:06 AM

    Hello Marshall,

    We will be glad to help you with the problem. However, we might need some more information. As I have checked the form, it seems to be set up correctly at the moment. Can you let us know if users get any error preventing form submit?

    Regarding 'unsecure site', our forms and embed codes are secured by default. May I ask if your form is embedded to a web page? If so, please share the link so we checked it too.

    We will wait for your reply. 

  • Profile Image
    acefootball
    Answered on April 20, 2019 at 02:43 AM
    Hi Victoria,
    Thanks for your help.
    The problems seem to be as follows.
    There are no buttons next to the single child or additional family member payment options on a mobile phone.
    There are no buttons next to the pay by credit card or cheque options.
    There is no submit button so the transaction can not be completed.
    I hope this helps.
    If you require further information please get in touch.
    Kind regards
    Marshall Phillips
    Ace Football
    07872 824527
    marshall@acefootball.co.uk
    www.acefootball.co.uk
    ...
  • Profile Image
    Nik_C
    Answered on April 20, 2019 at 03:21 AM

    I tested your form on my phone and I wasn't able to replicate:

    1555744726IMG_3AF34FD0ECEF-1.jpeg .     1555744751IMG_99C918D5A5AB-1.jpeg

    Fields are showing fine.

    Could you please tell us on which device(s) you tested and if the form is embedded in a website or your users are accessing directly since that would make a difference.

    Regarding Stripe not being secure, could you please let us know where did you see it?

    If you could share the screenshot: https://www.jotform.com/help/438-How-to-Post-Screenshots-to-Our-Support-Forum

    We'll wait for your response.

    Thank you!