Embedded form comes up with white screen on ipad.

  • Profile Image
    Dan Watson
    Asked on February 14, 2013 at 09:01 AM

    User account: hednesfordvalleyhighschool

    Hi, Ihave embedded a contact form onto a school website and it views perfectly on a PC or Mac, but on an iPad the whole page shows up as a white scrreen.

    You can view the page here: www.hednesfordvalleyhigh.staffs.sch.uk/new/contact

    The page has been designed in Dreamweaver with a template, which is why the top and bottom of the screens show up ok. The body comprises of a table with a Google Map embedded on the left and the Jotform on the right.

    I assume the forms are iPad compatible?

    Regards

    Dan Watson

  • Profile Image
    webmasterphi
    Answered on February 14, 2013 at 09:20 AM

    Hi Dan Watson,

    I am actually viewing your site in my ipad and i think it works well. Attached here is the screenshot of your site with my IPAD. If ever you still have problems or queries, please don't hesitate to post it here. Thanks for using JotForm. 

  • Profile Image
    hednesfordvalleyhighschool
    Answered on February 14, 2013 at 09:33 AM

     Hi webmasterphi
     
     
    Thanks for your reply.
     

    Your screen shot is not showing up in your post - it's being filtered by the school proxy. [EDIT; just viewed in on my iPhone - what iOS version are you using?]
     
    I've just checked the site on an iPad 2, iPad 3 and an iPhone 4S and on two different networks (in case our cache server is causing it) and it is not showing on any of them.
     
    Dan

  • Profile Image
    webmasterphi
    Answered on February 14, 2013 at 09:40 AM

    If that's the case, i think it might be the cache server that is causing it not to display. I tried it using IPAD 1 with Safari browser and till now its working perfectly. Please try to clear the cache, history and cookies of your IPAD or IPHONE.

  • Profile Image
    hednesfordvalleyhighschool
    Answered on February 14, 2013 at 09:47 AM

    I've tried bypassing the cache and even tried on 3G but with no luck. Resetting the internet settings on the device doesn't help either.

    On a couple of attempts, the page flashes up with the text and the google map, but goes white before the form shows up. Disabling the form's code brings up the page, so I know its the jotform code that the iPad is taking issue with.

    Dan

  • Profile Image
    hednesfordvalleyhighschool
    Answered on February 14, 2013 at 09:54 AM

    Fixed it -

    Changed from 'embed' to 'source' code and it's happy now.

    Thanks for your help.

     

    Dan

  • Profile Image
    webmasterphi
    Answered on February 14, 2013 at 10:02 AM

    It's my pleasure to help. Thanks for using JotForm.