Form not displaying correctly on some mobile devices

  • Profile Image
    Welshcampsite
    Asked on April 22, 2019 at 07:16 AM

    Some users with smaller mobile devices are not seeing the complete form (including the submit button) despite the form being set to scroll. Can you help?



  • Profile Image
    Kiran
    Answered on April 22, 2019 at 09:21 AM

    We have checked your web page using Android mobile which seems to be scrolling normally. However, as we check the web page using an iPhone emulator and see that the page is not scrolling. As we check the form using the direct link, the form is displaying normally with responsive mode. We notice that the form is embedded using iFrame embed method on your web page designed using Xara web designer.

    Could you check if you can adjust the height of the frame where the form is embedded in your Xara designer screen? Also, please try adding Mobile responsive widget to the form and see if that helps.

    Please get back to us if you need any further assistance. We will be happy to help. 

  • Profile Image
    Welshcampsite
    Answered on April 22, 2019 at 01:45 PM

    Thanks for the reply, I have added the widget but iPhone users are reporting no change. Would you mind re-running your tests and seeing if anything has changed?

  • Profile Image
    Welshcampsite
    Answered on April 22, 2019 at 01:47 PM

    Also, if I increase the height of the frame it makes things worse, the higher the number, less of the form is visible.

  • Profile Image
    Kiran
    Answered on April 22, 2019 at 02:55 PM

    I am still able to replicate the issue with the Safari browser on an iOS device. Please allow me sometime to check the issue further and get back to you with relevant information.

    Thanks!

  • Profile Image
    Kiran
    Answered on April 23, 2019 at 12:07 AM

    I have checked the form embedding on a normal HTML page which seems to be working normally using Safari browser with iOS device. The issue seems to be with the page design that is causing the scrolling issue on Safari browser, while it is displayed normally again on Android devices. Did you also create a mobile variant of your website from the designer?  Could you also check with Xara support to see if they can help with this issue?

    Thanks!