All of our forms are very slow

  • Profile Image
    Metropolinet
    Asked on April 29, 2019 at 03:58 AM

    Dear JotForm,

    All my forms are connected to CRM, all the forms are very very slow at opening the incident in CRM, it takes about a minute until they finish opening up the incident.in this forms i do not have a lot of conditionals. plaease take a look of the URL's:

    https://myavivim.co.il/jotform/?formid=80851048306454&source=site

    https://myavivim.co.il/jotform/?formid=80851286306458&source=site

    https://myavivim.co.il/jotform/?formid=80851095406457&source=site

    https://myavivim.co.il/jotform/?formid=80844008706456&source=site

    https://myavivim.co.il/jotform/?formid=80843413406452&source=site

    https://myavivim.co.il/jotform/?formid=80843200506447&source=site

    https://myavivim.co.il/jotform/?formid=73371380842457&source=site

    https://myavivim.co.il/jotform/?formid=80842449506461&source=site

    In addition I have a very problematic form ,Besides the fact that it takes him a long time to open a incident it is also takes a form a lot of time to load,I know that the form is loaded with many pages and rules and I tried to reduce them as much as possible and I have nothing more to do with it. Is there a solution other than to delete conditions? Because at the moment I will not be able to fill it with him because he is with me.(also in mobile)

    https://myavivim.co.il/jotform/?formid=83442965338466&source=site

    And what to do with the other slow forms?

    Im wating to your answer.

    Thank you.

  • Profile Image
    Welvin
    Answered on April 29, 2019 at 09:06 AM

    Only the last link that you have shared is not loading for me. All other forms are working and they're loading normally. Below is a snapshot of the first form from Chrome:

    15565422182019-04-29-001.png

    You have 160+ conditions. There are forms with conditions double this number, and they're working fine. I have inspected your form but I'm having a hard time checking the list due to the language. I'll try to check this further and let you know. 

    I would also like to know if who is "him" from your message. Is this person from the same company and connected on the same network? If not, would you be able to ask him to check the logs from the browser as I have shown you in the above image? That height of the window can be adjusted to show the full logs. 

    Also, were you able to replicate the problem when accessing these forms? Do you have another network to check the forms? Please check with your laptop/desktop PC because mobile is a different case. 

    Lastly, you may also consider checking your HTTP Headers because a bad configuration of that will cause your website to fail. I've found one error in the console related to the Content-Security-Policy.

    15565425312019-04-29-003.png

  • Profile Image
    Welvin
    Answered on April 29, 2019 at 09:41 AM

    The browser translate is not helping here :( I'm so sorry. I tried, but couldn't figure out if there are faulty conditions. Just one thing that may help is that, when setting up a conditional logic, you should not set up the opposite. For example, for Show and Hide conditions. If you have already set up field B to Show when field A is filled, do not set up another condition to Hide Field B when field A is not filled. Field B is automatically hidden by default in the form until the condition is met. 

    For branching conditions, say Show fields B, C, D when A is filled, but you would also like D to show only when C is filled, you should exclude D from the first condition, so...

    Show fields B, C when field A is filled. 

    Show field D when field C is filled. 

    I hope that helps. Please let us know if you need further assistance.

  • Profile Image
    Metropolinet
    Answered on April 30, 2019 at 01:02 AM

    Dear Welvin,

    First of all thank you about the quick response,


    Second, I confused with wrote "him", I mean everyone, it does not matter if I'm sitting at home or in the office from any network, this specipic form is very slow :

    https://myavivim.co.il/jotform/?formid=83442965338466&source=site

    I did a printScreen of logs from the browser, but if you will be more specific what you would like to see in the printScreen would be better

    1556600087log.PNG

    a. I will check with my team the HTTP headers issue and i will give you an answer.

    b. Because there are a lot of conditions in the form, I have to build the conditions as now. There are many contradictions between the conditions and they do not work If I do it differently, I tried already to change the logic but it is failed.


    c. I would be happy to know how forms with more conditions work well, and how to improve the time of increase and response on this form because we fail to fill the fotm at all.

    Thank you,

    Hila.

  • Profile Image
    roneet
    Answered on April 30, 2019 at 07:25 AM

    1. It seems that there are a lot of conditional conflicts on your form. When a field is set to be hidden conditionally, it will be only hidden if that condition is met and shown in all other cases. This way if there are many conditions to hide the same fields when the 1st condition is not met, the field must be always shown. But, there are other conditions to hide the field. This creates a conflict.

    I can suggest showing necessary fields conditionally instead of hiding the rest of the fields.

    2. There are some missing fields in your Form conditions, please correct these.

    15566230871.PNG

    3. You can indeed split your form, then redirect the users to the other form once the previous has been completed, this guide will help you redirect the users to a different page where you can use the form you want to redirect to upon the submission: https://www.jotform.com/help/38-Redirecting-Users-to-a-Different-Page

    Thanks.