Autopoulate not working

  • Profile Image
    jhellington71
    Asked on April 30, 2019 at 08:43 AM

    Hi


    I entered the following in your comments area on the guide page, have since seen that I had the brackets wrong, but even when i corrected its still not working. Please help.

    This is not working for me properly. I simply want to add the full name and email into the 2nd form to save them having to duplicate the effort.

    On the autoresponder only the email address is transposing into form 2. 
    On the thanks you page nothing is transposing
    The field names on both forms for the full name element is "name".

    Form 1. https://form.jotformeu.com/myusername/idea-form-sign-in
    Form 2. https://form.jotformeu.com/90862469051360

    Have inserted the following URL into to form 1's autoresponder on the link to follow

    https://form.jotformeu.com/90862469051360?name{name}&email={email}

    I've tried all manner of name fields including copying your example. I've two further forms to get sorted out.

    Cheers

    Why my username is on the first one I am also unsure?

  • Profile Image
    david
    Answered on April 30, 2019 at 11:10 AM

    The name field in form 2 has an ID of "yourName" instead of name:

    1556636781Capture.PNG

    I checked your form though and it looks like you have already made the updates to your URL:

    https://form.jotformeu.com/90862469051360?yourName[first]={name:first}&yourName[last]={name:last}&email={email}

    If anything still needs adjusting, let us know and we can take another look.