Using Authorize.Net secure and form conditions...

  • Profile Image
    doc4414
    Asked on February 20, 2013 at 06:41 PM

    I am using a condition on my form that if the payment option, "Credit/Debit card" is selected, then the form displays the payment field using Authorize.net option from Jotform.

    However, when the form is embedded on my 3rd party site securely, the credit card section of the form does not appear when credit card is selected, this only works when it is embeded unsecurely.

    The business site I am working on, already uses Authorize.Net, so this would be a perfect option to have on this form.  However, it will not display the relevant part of the form when I embed it as HTTPS vs. HTTP.

    The page URL attached to this post has the form embedded securely.. When you select credit card, it does not do what it is supposed to do.  Alternatively, the image uploaded to this post shows what it should do (works when form is not embedded securely).

    I guess my question is two part:   1) What am I doing wrong to make it fail when it is processed secure vs. not secure?2) If I embed it unsecure, would the credit card details still be secure (since it is running through Authorize.Net)?  

  • Profile Image
    Welvin
    Answered on February 20, 2013 at 09:19 PM

    Hi,

    Checking your form direct link, I can't find that option to your form: https://secure.jotform.us/30480545375152. Have you removed that? Embedding your form using iframe method: How to get your Form's Iframe Code might help you resolved that. In Iframe method, you can adjust the form height.

    For Secure Submission information, please kindly check this guide: http://www.jotform.com/help/63-How-can-I-receive-SSL-Submissions.

    Let us know if you need any further assistance.

    Thanks

  • Profile Image
    doc4414
    Answered on February 20, 2013 at 09:27 PM

    The option is still there.   But, when selecting Credit/Debit, it does not show the field to enter details.    

     

    I have made it an iFrame.. still not fixed.

     

    The label for the drop down box is "Payment method".  Additionally, I must mention.. on the form from the Jotform direct link, this option also does not work.. It's not simply on my end of things.

     

    Direct Link (Secure) https://secure.jotform.us/doc4414/res

     

    Direct Link (Unsecure)  https://form.jotform.us/doc4414/res

  • Profile Image
    Welvin
    Answered on February 20, 2013 at 09:38 PM

    Hi,

    I've cleared your forms cache from our end, the form should now works fine on your website. Please kindly check and clear your browsers cache, if needed.

    Thanks

  • Profile Image
    doc4414
    Answered on February 21, 2013 at 05:46 PM

    It appears to be working now, thanks!

  • Profile Image
    jonathan
    Answered on February 21, 2013 at 06:27 PM

    You are quite welcome. Please contact us again anytime should have any other inquiry.

    Thanks.