Does JotForm work with iPad Safari?

  • Profile Image
    hdunsmore
    Asked on February 21, 2013 at 12:18 PM

    The heading states it all.

     

    iPad shows a page with all HTML except the JotForm form.

  • Profile Image
    abajan
    Answered on February 21, 2013 at 01:45 PM

    Hi Henry,

    I just checked your page at BrowserStack and it shows up fine there on iPad on Safari. However, it may be a caching issue causing it not to show up on your end. As such, I've cleared the form's cache from our end. Please check the web page now and if it's still not appearing, try substituting

    http://www.jotformpro.com/jsform/22745868741970

    for

    http://form.jotformpro.com/jsform/22745868741970

    and us know if that helps.

    Thanks.

  • Profile Image
    hdunsmore
    Answered on February 25, 2013 at 08:24 AM
    I cleared the cache with no result to page. My iPad sped up, though. Henry
  • Profile Image
    jefreylandicho
    Answered on February 25, 2013 at 08:58 AM

    Can you please try embedding the form using IFRAME and see if it works? 

  • Profile Image
    hdunsmore
    Answered on February 25, 2013 at 10:54 AM
    Unfortunately, my iPad is in Toronto and my investigation into the iPad form issue is on hold. I uploaded an image to your site of the last result I received.
    Although I can use Opera Mini or Icab (don't know what they are) as I mentioned before, I think the onus is on JotForm to make any and all browsers work.
    Henry
  • Profile Image
    EltonCris
    Answered on February 25, 2013 at 11:39 AM

    Hi Henry,

    The form should work properly on iPad. Like Abajan, the form on your page displays properly on iPad - Mobile Safari Browser. Check this screen.

    We would appreciate if you could post a screenshot on how it displays on your end. You can Upload the screenshot here and give us the image URL. Thanks!

  • Profile Image
    hdunsmore
    Answered on February 26, 2013 at 10:49 AM
    Thanks for the continued input. I will assume that it only doesn't work for me but works for everyone else. I don't have anyone to check with. I'll go to Staples store and see if it works on their demo.