Form Designer>Advanced Designer: cannot save changes/edits in the form

  • Profile Image
    benedictcamara
    Asked on May 24, 2019 at 07:04 AM

    Hi

    The advanced form builder doesn't seem to be working or saving properly

    I tried editing the colors of headers among different forms, not one would change after saving

    I tried clearing the cache.

    I tried using a different browser

    I tried private/incognito browser modes

    I tried making a blank form and trying to change header colors

    Nothing works

    Also now I am trying to change button colors and styles and it still does come out in the preview or actual form after I save the changes

    Been using Jotform since 2015 so i'm not a newbie here either

    Im tired of having to manually do CSS. Note CSS only works if it is done in basic form designer. Once it is done in advanced designer/css then the changes once again are not saved

  • Profile Image
    gerardw
    Answered on May 24, 2019 at 07:47 AM

    If you are referring to this form: https://www.jotform.com/91407001521441, I think the headers are matching the form background. Do let us know what color are you trying to provide for the headers?

    If you are trying to change the button color and style, I can see there is only one button in the form - the Submit button. To change the style for the Submit button, you need not go the Advanced form Designer. Just go to the Submit button properties, where you can change the button style.

    15586984592405_2.png

  • Profile Image
    benedictcamara
    Answered on May 24, 2019 at 08:50 AM

    Here I made a new blank form

    https://form.jotform.me/91433147939464

    Stripped it of all colors

    Tried using the Advanced Editor to change background colors, font colors, change submit button to block.... it doesn't work

    I dont want to be using CSS all the time

    Also I opened my older forms, the colors of the headers and buttons and fonts cannot be changed as well

  • Profile Image
    benedictcamara
    Answered on May 24, 2019 at 08:58 AM

    Yes my previous form header colors do indeed match the background color because I HARD CODED the CSS to make it so because the Jotform advanced designer IS NOT WORKING for me

    I want to know how to make the advanced designer work like it should

    I have tried on 2 other OLD forms, both also experiencing the same problem.

  • Profile Image
    gerardw
    Answered on May 24, 2019 at 09:02 AM

    Please check the sample form you shared above. I've changed some sample colors using the Form Designer itself. I did not go into the Advanced Form Designer.

  • Profile Image
    benedictcamara
    Answered on May 24, 2019 at 09:06 AM

    Yes I saw you changing it

    But Gerard you changed the forms background color and font

    My problem is not the forms background color and font. I hope this is clear to you by now

    My problem is changing the background color and font of the HEADER

    Can you see how to change that without using custom CSS?

  • Profile Image
    benedictcamara
    Answered on May 24, 2019 at 09:07 AM

    Also you were not able to make the submit button into a block type submit button like I typed

  • Profile Image
    gerardw
    Answered on May 24, 2019 at 09:28 AM

    I just tried to change the background color and the font of the header using the Advanced Form Designer. Please check the screenshot below and your form itself. Once I saved and went back to the form builder, it retained the changes.

    15587044652405_6.png

    I'll get back to you on the Submit button.

  • Profile Image
    gerardw
    Answered on May 24, 2019 at 09:37 AM

    Here are the details on the Submit button. Changed it to block format, changed background color, font type, and color too. Saved on Advanced Form Designer and it retained the changes in the form builder.

    15587050222405_7.png

  • Profile Image
    benedictcamara
    Answered on May 25, 2019 at 05:56 AM

    Hi Gerard

    I see it is working with you. The big question is why is it not working with me?

    Here I uploaded a youtube video live screen recording to show you what is happening on my end

    https://youtu.be/u9CVWkEkU28

    As you can see it is not working

    I have tried the following

    1. Delete all caches, even the form cache

    2. Log in-Log out

    3. Use different browsers (IE, Chrome, Edge)

    4. Use private/incognito mode (IE, Chrome, Edge)

    5. Try editing other forms, even older ones. All does not work

  • Profile Image
    Richie_P
    Answered on May 25, 2019 at 08:18 AM

    Hi benedict,

    I have checked your form and made some edits in the advanced designer and I was able to save the changes.

    If you want, we can edit the form for you. Just let us know how you want your form to look or what changes would you like to make.

    I have also cleared your form cache, can you please test your form again?

    Looking forward for your response.

  • Profile Image
    benedictcamara
    Answered on May 25, 2019 at 08:47 AM

    Hi Riche,

    It is still the same. I tried on different forms as well. Everything I do with the advanced designer does not save. It is obvious now pressing the SAVE on advanced designer does not save the changes at all.

    Even CSS on the advanced designer does not save and cannot be viewed on the basic designer. But if I type the CSS on the basic designer and save then it can be seen in the advanced designer CSS.

    So the issue here is the save button. I think somehow it is not saving the changes to jotform servers.

    I really appreciate the offer to do the changes for me, but I make forms often and so having to wait for changes to be made for us would be counterproductive.

    There must be a way to solve this 

  • Profile Image
    Richie_P
    Answered on May 25, 2019 at 09:06 AM

    May  we know if you have enabled pop-up blockers in your form? If yes, can you please disable them when editing?

    Can you please share to us the console log report when you try to save your edits in the advanced designer?

    You may check this guide:https://www.jotform.com/help/453-How-to-get-a-console-report-from-most-common-browsers

    To post screenshots in the thread, here is a guide:How-to-add-screenshots-images-to-questions-to-the-support-forum


  • Profile Image
    benedictcamara
    Answered on May 25, 2019 at 09:54 AM

    No pop up blockers on my 3 browsers

    Here is the screenshot. It seems there is indeed some problem

    1558792403screenshot.jpg


  • Profile Image
    Kiran
    Answered on May 25, 2019 at 02:58 PM

    I have also tried making some changes on your test form and was not able to replicate the issue. I also notice that the same errors have been displayed in my browser console, but the changes in the advanced Form Designer have been saved without any issue. 

    I suspect that a third party software like anti-virus or the firewall is blocking some scripts. Would it be possible to check if the changes are saved by using a different PC or network? You may check on your mobile browser and see how it works. 

    Please get back to us if the issue still persists. We will be happy to assist. 

  • Profile Image
    benedictcamara
    Answered on May 25, 2019 at 06:12 PM

    Hello Kiran,

    I did the following

    1. Disable firewall and anti virus on my laptop. Still same

    2. Try my seldom used laptop with fresh install of windows 10 and latest updates with built in windows firewall and anti-virus disabled. Still same

    3. I went to the internet shop down the street. They use PC not laptop. Still the same

    4. I went to a 2nd internet shop in my area. Still same

    5. I connected my laptop to my mobile phone data and not my internet service provider. Still same.

    To summarize:

    1. Everything I do using basic designer saves.

    2. Everything I do in advanced designer, even the most basic things, does not save at all

  • Profile Image
    benedictcamara
    Answered on May 25, 2019 at 07:25 PM

    Another odd thing I noticed.

    In advanced designer, if I click save, it goes through the usual "saving" animation, says saved, then offers to preview.

    BUT if I edit something else immediately after and click save, then it stays forever in the "saving" animation and the only thing to do is leave without saving.

    This behavior is consistent among all the computers and laptops I have tested on

  • Profile Image
    Richie_P
    Answered on May 26, 2019 at 12:53 AM

    I have tested your form again and tried to save and edit but I can't seem to replicate the issue at my end.

    Here is my screen cast:

    15588458551.gif

    I have escalated the issue to our developers for further investigation.

    You will be notified via this thread once updates are available.


  • Profile Image
    benedictcamara
    Answered on May 26, 2019 at 01:20 AM

    I am beginning to think my country is somehow being blocked. Think about it:

    2 different laptops

    3 different browsers

    2 different desktops from 2 different computer shops

    3 different internet service providers

    I even moved my account to the European servers

    All have the same result for me here.

    I will try using a VPN now to and see what happens

  • Profile Image
    Kiran
    Answered on May 26, 2019 at 02:31 AM

    I see that the issue has already been forwarded to our backend team for further investigation. We'll let you know here once we have any information in this regard. Also, please let us know the results with VPN that might help with checking the issue further.

    Thanks!

  • Profile Image
    benedictcamara
    Answered on May 26, 2019 at 03:46 AM

    So I tired using two different VPN's

    After trying different continents I got this

    Anyway, still not saving. Tested in Germany, USA, Japan locations for VPN

    1558856652vpn.jpg

  • Profile Image
    Welvin
    Answered on May 26, 2019 at 08:19 AM

    Thank you for trying and informing us here. The IP address assigned by your VPN is likely assigned to someone before which has been suspended due to our terms. The ticket is already raised to our backend team. Once we have an update, we will let you know here. 

  • Profile Image
    benedictcamara
    Answered on June 05, 2019 at 10:37 PM

    Hello

    Has there been a solution for this? Up till now the advanced designer is not saving changes

  • Profile Image
    Richie_P
    Answered on June 06, 2019 at 12:11 AM

    We are sorry for the inconvenience.

    Just to clarify, are you editing the form as the main account or as the sub-user?

    I have checked your account and you do have a sub-user.

    We have tested your account and we are able to save the changes in the Advanced designer.

    Can you try editing the form as the main account user?

    Let us know how it goes.

  • Profile Image
    benedictcamara
    Answered on June 06, 2019 at 06:18 AM

    Hello Richie

    I have been using the account as the main user

    But to give it a try I have deleted the sub-user

    And I still cannot do it 

    Here is a video again just taken now for you to see https://youtu.be/0NQiETOzcNE

  • Profile Image
    gerardw
    Answered on June 06, 2019 at 08:09 AM

    Thanks for the update. We are sorry for the inconvenience caused. Let me get in touch with our backend team. We'll get back with an update.

  • Profile Image
    benedictcamara
    Answered on July 05, 2019 at 05:38 AM

    Hello guys


    It has been over a month! I still have the same problem


    Has there been no solution to this?

  • Profile Image
    benedictcamara
    Answered on July 05, 2019 at 05:43 AM
    Hello guys
    It has been over a month! I still have the same problem
    Has there been no solution to this?
    ...
  • Profile Image
    gerardw
    Answered on July 05, 2019 at 06:44 AM

    Hello,

    We are sorry for the inconvenience caused. To test whether any changes made are getting successfully saved in the Advanced Designer, I checked your form "4THPNP COMMUNITY FUN RIDE", tested the Advanced Designer by changing the label color to black from the current navy blue.

    I saved the color and when I went back to the Form Builder, the color was successfully changed to black. So I guess, the save function is now working in the Advanced Designer. Please check and let us know the update. 

    Note: I have now reverted the label color in your form back to the original navy blue color.

    Meanwhile, our back end team is also working on this issue and we will apprise you of updates as soon as we receive one.

     

  • Profile Image
    benedictcamara
    Answered on July 05, 2019 at 07:12 AM

    I have recorded my attempt to recreate what you described

    Here is the screen video https://youtu.be/EJLny6hfjoA

    So doesnt work here

    By now I have tried it on different computers, computer shops, laptops, desktops, different versions of windows, with firewall, without firewall, with antivirus, without antivirus, with vpn, without vpn, edge, chrome, internet explorer, firefox, latest versions, older versions, incognito mode, clear all caches, different internet providers, I am so sad I cannot be creative with my forms

    Hope we can find something soon

  • Profile Image
    gerardw
    Answered on July 05, 2019 at 07:33 AM

    I can see that the issue is still recurring at your end. Please let me send an update to our backend team regarding your latest update. We will keep you posted on updates as soon as we receive them.

  • Profile Image
    eugene
    Answered on September 25, 2019 at 02:29 PM

    Hello,

    We are sorry for our late response about this issue.

    We made several changes related to the Advanced designer, issue should be resolved now.

    Can you check it on your side and let us know if the issue persists?

    Thank you.

  • Profile Image
    benedictcamara
    Answered on October 01, 2019 at 11:11 AM

    HEY GUYS!!!

    Congratulations it finally works again

    Really glad with this response as I had actually given up because it looked like I was a crazy person experiencing this problem

    2 of my suggestions were included in the updates as well, one for mobile and the other for submission views

    Good job