Won't display hidden fields based on condition

  • Profile Image
    DiscoveryCharterSchools
    Asked on June 03, 2019 at 03:14 PM

    I have a form that is suppose to display the credit card payment info, and a text box and the Next (submit) button if you select payment by credit card.  Also, if you select payment by E-Check it is suppose to display the Next (submit) button.

    What it does is if I select payment by e-check, nothing new is displayed.  If I select payment by CC, it displays the CC payment box and the submit button but not the text box.

    I have been trying many different ways to get this to work and can never get it right.  So I need your help.

     

  • Profile Image
    Richie
    Answered on June 03, 2019 at 04:45 PM

    May we  know if this is how you want your form to work?

    Here is a screen cast:

    You may try my sample Form at this link:https://form.jotform.com/91535878069977

    You can also clone it to check the conditions.

    Here is a guide:https://www.jotform.com/help/42-How-to-Clone-an-Existing-Form-from-a-URL

    Please give it a try and let us know if you have further questions.

  • Profile Image
    DiscoveryCharterSchools
    Answered on June 03, 2019 at 06:33 PM

    almost but not quite.  I am passing the payment amount, name and email to the e-check form.  Yours does not do that.

    I couldn't verify what happened when I paid by CC as I got a PCI error.  But it is suppose to go to the Thank You page.

    Thanks

  • Profile Image
    jherwin
    Answered on June 03, 2019 at 08:29 PM

    I answered your query regarding the submit/next button that is not showing when you selected the "Pay with E-Check" payment method here: 1843216.

    Please refer to that thread for any related questions and/or follow-ups.

    I couldn't verify what happened when I paid by CC as I got a PCI error.  But it is supposed to go to the Thank You page.

    Could you please check if your Authorize.Net credentials are correct and if it's for live mode? Also, Have you tried setting your Customer ID as not required in your authorize account?

    Guide:

    1.) Log in to your Merchant Account.
    2.) Click on Settings and Profile > Payment Form > Form Fields.
    3.) Uncheck the Required box for the particular Field.

    If the issue persists, please show us a screenshot of the error so we can further investigate the issue.

    Guide: How-to-Post-Screenshots-to-Our-Support-Forum