Cards> Input table > Multi-type column > deleting a column = crashes "unexpected error occurred control_matrix"

  • Profile Image
    BethInnes
    Asked on June 07, 2019 at 10:25 AM

    Cards> Input table > Multi-type column > deleting a column
    Results in multiple crashes with error message that doesnt go away (even after refreshing, returning and cloning form - "unexpected error occurred control_matrix"

    1. I'm trying to create a multi-type column table in a question card. 
    2. I want 3 columns i total...two columns with check boxes and one column with text box
    3. The multi-type card automatically creates 4 columns with radio buttons
    4. I go to card settings to change the field option to multi-type 
    5. I then go to the first three columns and select the dropdown in each one to assign the option type (check box, check box, type box)
    6. When I go to delete the 4th column - the card crashes and disappears. Instead, this text appears where the card has disappeared:
    "unexpected error occurred control_matrix" 
    7. I've tried to create this card over a dozen times and the same thing happens
    8. I've tried refreshing the page, logging in and out of Jotform, clearing my browser cache, trying to work in different browsers (Safari, Chrome), cloning the questionnaire..
    9. When I try again, the card continues to crash and each time the 'unexpected error occurred control_matrix' message appears
    10. The unexpected error occurred control_matrix is logged each time and remains on the page. Please see below the screengrab:


    I think your system has a bug? All I want to do is create a multi-type form with 3 columns made up of check boxes and text boxes! Help needed!

    Original form: https://eu.jotform.com/build/91543415017350

    Clone of the original: https://eu.jotform.com/build/91573820322352

    1559917371Screen Shot 2019-06-07 at 15.2


    1559917257Screen Shot 2019-06-07 at 14.5


  • Profile Image
    Victoria_K
    Answered on June 07, 2019 at 11:49 AM

    Apologies for the trouble. I have performed some tests and it seems there is a bug for Multi Type Columns. I am reporting this to our developers. Please consider using all 4 columns or different input type until this is fixed. We will inform you via this thread. 

    Thank you for letting us know about this problem.

  • Profile Image
    BethInnes
    Answered on June 10, 2019 at 09:29 AM

    Thanks for looking into fixing this issue.

    Unfortunately, using 4 columns is not going to work for the nature of the question on this card.

    Can you give me an idea of when this issue/bug might be fixed please?

    Thank you.

  • Profile Image
    IvayloK
    Answered on June 10, 2019 at 10:21 AM

    We have reported this to our dev team. We can not give you any time frame, but we will keep you apprised on this same thread, when there is an update.

  • Profile Image
    yakupteke
    Answered on June 19, 2019 at 05:29 AM

    Hi,

    The issue should be fixed. Could you please check your form again?

    Thank you.