multiple payment form works in preview, but not on website

  • Profile Image
    aklettner
    Asked on February 25, 2013 at 08:07 PM

    I created a simple form to collect information for payment via paypal or by personal check.  The forms all worked fine in preview but when I embedded the code into a webpage the payment forms are not coming up.  I am having a hard time figuring out what I am doing wrong.  Help?

  • Profile Image
    jeanettebmz
    Answered on February 25, 2013 at 09:40 PM

    I just checked your site and I was able to either see the Paypal section or the Check section

    Can you please let us know if you still need help?

  • Profile Image
    aklettner
    Answered on February 25, 2013 at 09:46 PM

    I can see it fully in Chrome, but I cannot seem to get it to come up in IE. 

  • Profile Image
    jeanettebmz
    Answered on February 25, 2013 at 09:50 PM

    Can you please clear your browser cache,? I used both and had no problem with that

  • Profile Image
    aklettner
    Answered on February 25, 2013 at 09:54 PM

    I can also get it with Firefox on another computer but not in IE on that computer.

  • Profile Image
    Answered on February 25, 2013 at 10:00 PM

    Still not working in IE for me. 

     

  • Profile Image
    Answered on February 25, 2013 at 10:02 PM

    I just see the top line which says PayPal or Personal Check.

  • Profile Image
    jeanettebmz
    Answered on February 25, 2013 at 10:06 PM

    Yes, you are correct, I am able to see the problem .

    The only possibility I can think of  while inspecting your page source code is that the current DOCTYPE declaration you have, might be the problem:

    <!DOCTYPE HTML PUBLIC "-//W3C//DTD HTML 4.01//EN" "http://www.w3.org/TR/html4/strict.dtd">

    I would suggest you to change it to the one below:

     

    <!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Transitional//EN" "http://www.w3.org/TR/xhtml1/DTD/xhtml1-transitional.dtd"> 

     

    Let me know if this help

  • Profile Image
    aklettner
    Answered on February 25, 2013 at 10:18 PM

    I am lost on that, but I will ask the web host people for help with it.

  • Profile Image
    jeanettebmz
    Answered on February 25, 2013 at 10:27 PM

    Ok, let us know if you need more help

    Cheers!