Why Dynamic Tagging not working in Infusionsoft integration?

  • Profile Image
    candacescholz
    Asked on June 12, 2019 at 07:02 PM

    Dynamic tagging is not working to add tags to infusionsoft. Should I just do regular tagging until this is fixed?

  • Profile Image
    jherwin
    Answered on June 12, 2019 at 07:53 PM

    We are sorry for the inconvenience this may have caused. Can you please confirm whether the issue is happening in this form?

    https://form.jotform.com/81766956191975

    I checked that form and it's currently set to static tagging. Also, your infusion soft doesn't have any API call name, can you add one with dynamic tagging? I tried the dynamic tagging on our end and it's working fine.

    You can clone your form or create a new form to test the dynamic tagging on your end. I suggest making an actual submission on your form to confirm if it's working.

    Related Guide: Achieving-InfusionSoft-Campaign-Goals-with-JotForm

    Please give it a try and let us know if the issue persists so we can further investigate this.

  • Profile Image
    candacescholz
    Answered on June 13, 2019 at 05:43 PM
    Hi, this is indeed the form. I switched it back to static tagging since I
    needed the form to work. I will create a clone to test - but I am unclear
    as to how the API call name comes into play. Can you explain further how to
    make that work within Infusionsoft?
    ...
  • Profile Image
    candacescholz
    Answered on June 13, 2019 at 05:43 PM
    Also - the instructions for this do not have anything regarding API
    https://www.jotform.com/help/513-How-To-Use-JotForm-s-Infusionsoft-Dynamic-Tagging
    ...
  • Profile Image
    EltonCris
    Answered on June 13, 2019 at 07:24 PM

    If you mean to say you're populating the Infusionsoft tags (hidden checkbox field in your form) through API with your form source code, that's possible. Basically, you will just have to add your checkbox field values in the hidden Infusionsoft Tags checkbox field, whichever method you use.

    Anyway, I just tried Infusionsoft Dynamic Tagging on Integration and it is working.

    My Form: https://form.jotform.com/91637343942967?infusionsoftTags=Cold

    As you can see I have one tag that is populated through URL parameter (Cold) and I have one tag that is set as the default value on the checkbox field.

    Here's the result:


    Please try it again and ensure that there is at least one checked option in your hidden Infusionsoft Tags checkbox field.

  • Profile Image
    candacescholz
    Answered on June 14, 2019 at 05:43 PM
    This is exactly what I did on the form and they are not populating/being
    added inside Infusionsoft. Still confused about how to assign them to the
    fieldsHere is a duplicate with my attempt at dynamic tagging -
    https://form.jotform.com/91646805815969
    ...
  • Profile Image
    jherwin
    Answered on June 14, 2019 at 07:00 PM

    Here's what my colleague Infusionsoft integration looks like:
    1560553066remove2.png

    I noticed that tags are not actually included in mapped fields.
    1560553101remove1.png

    Please try removing Leadsource and uncheck the Marked Opt-In Email Status to if submissions will go or not.

    Please give it a try and let us know how it goes.

  • Profile Image
    candacescholz
    Answered on June 17, 2019 at 02:43 PM
    I made those changes - still the same result. No tags populating in
    infusionsoft.
    [image: Screen Shot 2019-06-17 at 10.52.38 AM.png]
    [image: Screen Shot 2019-06-17 at 10.52.22 AM.png]
    ...
  • Profile Image
    EltonCris
    Answered on June 17, 2019 at 05:23 PM

    Sorry, we couldn't view the screenshot. Could you please upload it directly in your thread here https://www.jotform.com/answers/1855316? Guide: https://www.jotform.com/help/438-How-to-Post-Screenshots-to-Our-Support-Forum

    Also, when you use Dynamic Tagging, how are you populating the hidden checkbox fields? You need to check those tags that you want to pass to Infusionsoft.

    I checked it on your form now but you seem to have switched to Static Tags.

    We'll wait for your updates.

  • Profile Image
    candacescholz
    Answered on June 17, 2019 at 07:27 PM

    In my previous message, i had given you a direct link to a clone of the form where I am following your instructions. You must be looking at the other form. Please let's use this one for this support ticket- 

    https://form.jotform.com/91646805815969

    Here are the screenshots directly to our thread. As you can see, the tags are checked under advanced.

    1560813950Screen Shot 2019-06-17 at 10.5

    1560813931Screen Shot 2019-06-17 at 10.5

  • Profile Image
    jherwin
    Answered on June 17, 2019 at 08:41 PM

    Try this method and see if will work: How-To-Apply-Infusionsoft-Tags-Depending-on-Form-Answers.

    Create a condition like this: If name is filled then insert "tags" to "Infusionsoft tags field".

    You can also try adding calculation value to the infusionsoft tags.

    Guide: How-to-Assign-Calculation-Value