What is JotForm?
JotForm is a free online form builder which helps you create online forms without writing a single line of code. No sign-up required.

At JotForm, we want to make sure that you’re getting the online form builder help that you need. Our friendly customer support team is available 24/7.

We believe that if one user has a question, there could be more users who may have the same question. This is why many of our support forum threads are public and available to be searched and viewed. If you’d like help immediately, feel free to search for a similar question, or submit your question or concern.


  • Profile Image

    Lightbox and Feedback button not working in IE8

    Asked by ACAlliance on March 23, 2011 at 11:39 PM

    Hi, 

    Reference this website: http://acalliance.org, I have added the lightbox code to the two green buttons at the top of the page next to the logo, "Join Now" and "Donate".  The code works great when testing in Chrome and Firefox, but when clicking either button using IE8, nothing happens.  

    Another issue is with the Feedback button.  If you view the site using Chrome or Firefox, you will see the "Donate Now" feedback button attached to center right of screen.  But if you view the site in IE8, the feedback button is nowhere to be found.

    Thanks,

    Matt

    Page URL:
    http://acalliance.org

    IE problem Form not working IE
  • Profile Image
    JotForm Support

    Answered by NeilVicente on March 24, 2011 at 04:02 AM

    Hi,

    I found two feedback embed codes in your page, one inside the <head></head> tags and the other in the <body></body>. Try removing one of them. I have a feeling having two of them in a page causes a conflict with the scripts used to render them. I could be wrong though.

    I'll be awaiting your feedback.

  • Profile Image

    Answered by ACAlliance on March 26, 2011 at 03:35 PM

    Hello,

    The script in the <head> section was to display the Feedback button attached to the screen.  I removed that code, and tested to see if the Join Now and Donate buttons (code located in <body> section) next to the logo would work now in Internet Explorer.  They're still not working in IE.  

    I verified that everything still works in Chrome and Firefox however (minus the feedback button since code was removed).

    Thanks,
    Matt 

  • Profile Image

    Answered by ACAlliance on March 27, 2011 at 09:53 PM

    Hi,

    The forms are still not working in Internet Explorer...  I have two JotForm forms that need to open in a lightbox when the particular buttons are clicked.  They both work in Chrome and Firefox.  In Internet Explorer, you can click the buttons, but nothing happens.

    Also, what is the workaround to get the Feedback button to appear in Internet Explorer.  Again, the button shows up fine in Chrome and Firefox, but is nowhere to be found when browsing the site in IE.  I need these issues corrected as soon as possible.

    Thanks,
    Matt 

  • Profile Image

    Answered by ACAlliance on March 27, 2011 at 10:38 PM

    Here's a link to the screenshot: http://awesomescreenshot.com/035a8j00e 

  • Profile Image
    JotForm Support

    Answered by liyam on March 29, 2011 at 05:04 AM

    Hello Matt,

    I have checked your page and figured what's wrong.

    Inside your code you have called the javascript source multiple times:

    <script src="//www.jotform.com/min/g=feedback" type="text/javascript">
    new JotformFeedback({
    formId:'xxxxxxxxxx',
    base:'http://www.jotform.com/',
    windowTitle:'Some title here',
    background:'#90BD2E',
    fontColor:'#FFFFFF',
    type:1,
    height:800,
    width:650
    });
    </script>

    What you have to do is remove src="//www.jotform.com/min/g=feedback" in the next two scripts.  So for the next feedback/lightbox scripts just use the <script type="text/javascript"> tag, without the src property and its value. 

    <script type="text/javascript">
    new JotformFeedback({
    formId:'xxxxxxxxxx',
    base:'http://www.jotform.com/',
    windowTitle:'Some title here for 2nd and 3rd form',
    background:'#90BD2E',
    fontColor:'#FFFFFF',
    type:1,
    height:800,
    width:650
    });
    </script>

    This is because you have called already the file in the 1st lightbox script.  In IE this has already downloaded the file and if you try downloading it again would mean a conflict in your page.

    Hope this helps.

  • Profile Image

    Answered by ACAlliance on March 29, 2011 at 10:07 PM

    Thanks - that did the trick!!!

  • Profile Image
    JotForm Support

    Answered by liyam on March 30, 2011 at 03:37 AM

    Thats good to hear.

    If you have other inquiries, please don't hesitate to ask.

    Thanks :)

  • Profile Image

    Answered by emmanuelmoreno on August 18, 2011 at 09:21 AM

    Hi,

     

    I seem to be having a similar problem. I currently have a page (http://emmanuelmoreno.weebly.com/donate.html) that has 6 links to lightboxes. They all work fine in FF but nothing happens in IE when clicked. As suggessted, I have removed the src tag from all codes but the first, but that didn't seem to resolve the problem. I also tried removing all the links except for one (the one with the src tag), leaving just one lightbox code on the page, but that didn't work either. Is there anything elso that might be conflicting with the lightbox code?

     

    Thank you

  • Profile Image
    JotForm Support

    Answered by NeilVicente on August 18, 2011 at 12:31 PM

    @emmanuel

    Your site has a script that conflicts with the lightbox script codes, particularly this line:

    <script type='text/javascript' src='//cdn1.editmysite.com/libraries/prototype/1.7-custom/prototype.min.js'></script>

    I am not sure which functions in your page are dependent on this script but removing it will make your lightbox forms work perfectly fine under IE.

    Hope you find this helpful. Let us know if you need further assistance. Thanks!


    Neil

  • Profile Image

    Answered by emmanuelmoreno on August 19, 2011 at 05:45 PM

    You got it! Thanks Neil - that indeed did the trick!!!

  • Profile Image

    Answered by max on October 28, 2011 at 01:38 AM

    Please see my problem on http://www.ghee.si/narocilo . When you click on Narocilo Ghee nothing happens in IE8,7... FF works great.

  • Profile Image
    JotForm Support

    Answered by liyam on October 28, 2011 at 05:15 AM

    Hello Max,

    I checked your page and it seems to be conflicting with mootools.js.  May we know what part of the page you're using mootools? 

    Thanks.

  • Profile Image

    Answered by sep_automovel on August 24, 2012 at 08:44 AM

     

    Hello!

    I tried to make all the above changes, but continues with the same problem on my site. The lightbox does not open in IE. You can help me?

    Thank you!

  • Profile Image
    JotForm Support

    Answered by idarktech on August 24, 2012 at 10:31 AM

    @sep_automovel,

    Adding this doc type at the top part of your page source may help.

    <!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.1//EN" "http://www.w3.org/TR/xhtml11/DTD/xhtml11.dtd">

    Try and let us know if this doesn't work. Thanks!

  • Profile Image

    Answered by sep_automovel on August 24, 2012 at 10:44 AM

    @idarktech

    I put the code, but unfortunately continued with the same problem.

  • Profile Image
    JotForm Support

    Answered by idarktech on August 24, 2012 at 10:56 AM

    @sep_automovel

    Can you please repaste the code without adding any spaces? Just copy and paste it as it is. Copy it here: http://pastebin.com/raw.php?i=Svue5yh7

    Update us if the problem still persist. Thanks!

  • Profile Image

    Answered by sep_automovel on August 24, 2012 at 11:07 AM

    @idarktech

    Show!

    Now yes it worked.

    Fixed the problem and even lined my social icons.

    Thank you!

  • Profile Image
    JotForm Support

    Answered by jonathan on August 24, 2012 at 11:50 AM

    @sep_automovel

    Glad to know everything sorted out. Thank you for updating us.

  • Profile Image

    Answered by fcrp on July 01, 2013 at 07:47 PM

    MINE IS STILL NOT WORKING _ NOE OF THESE ANSWERS ARE NOT WORKING FOR ME!

  • Profile Image

    Answered by pinoytech on July 01, 2013 at 11:09 PM

    @fcrp

    Can you please open a separate thread with regards to the issue? Please include also URL of your website where your form embedded for further assistance?

    Thank you!

  • Profile Image

    Answered by Ant5hony  on November 04, 2014 at 03:09 AM

    Hi I have the same problem in IE8 - IE10 on www.mtlabs.co.za Please could you have a look and see what is happening? My client is Shouting at everyone - PS this is the wordpress plugin BTW
  • Profile Image

    Answered by Abu on January 19, 2015 at 10:46 AM

    I am running the same problem. I am trying to set up a booking system on my website http://buffalo-airporttaxi.com/ and used this feedback code at the bottom of my page

    <script src="//d2g9qbzl5h49rh.cloudfront.net/static/feedback2.js?3.2.4970" type="text/javascript">

      new JotformFeedback({

         formId : "50078670502148",

         buttonText : "Book Official Buffalo Airport Taxi Service Now",

         base : "http://jotform.us/",

         background : "#F51202",

         fontColor : "#FFFFFF",

         buttonSide : "bottom",

         buttonAlign : "center",

         type : false,

         width : 700,

         height : 1000

      });

    </script>

    but it seems like not working as well, I see the box popped up when I click the button but the form doesn't show in the box it's a white blank box with only the heading tittle at the top. what do you think is the problem? Thank you in advance. 

    http://buffalo-airporttaxi.com/