Hidden field content disappeared

  • Profile Image
    Ontrex
    Asked on June 27, 2019 at 10:10 AM

    I got a form for which I provide a parameter via URL, i.e. https://form.jotformeu.com/91764494758374/?uid=12345 to prepopulate one of my hidden text fields.

    The parameter seems to get entered into the field correctly,as a) the condition I have set for an empty uid field will not be executed and b) I can see the parameter has been entered if I unhide the uid text field for testing.

    However, if the form is submitted, neither the email sent to me nor the submission table in Jotform does contain any value for uid. How come? What‘s wrong in my form?

    As a workaround I cloned my form to 91774354581364, deleted the text field for uid, created a new text entry and again named it uid. In this form my uid will be displayed in the email and the submission list.

    I cannot see what I have done wrong in the 91764494758374 form as to my view the 91774354581364 form is identical. It‘s just that the latter works and the former does not.

    Please note that the 91774354581364 is an active form that is displayed on my website for customers to enter data into, so please refrain from making any changes there. The 91764494758374 form is no longer active.

    Thank you.

    Thttps://form.jotformeu.com/91764494758374https://form.jotformeu.com/91764494758374

  • Profile Image
    Alan_D
    Answered on June 27, 2019 at 11:45 AM

    You can save your hidden field values by an option in the settings. 15616502083.png15616502175.pngCan you please give it try? 

  • Profile Image
    Ontrex
    Answered on June 27, 2019 at 12:11 PM

    This seems to help, thank you!