Jotform Mobile Forms: Form unable to download to offline forms and displaying error

  • Profile Image
    captainswallow
    Asked on June 30, 2019 at 10:46 PM

    After many hours of working on this form and testing it as I went along, I finally submitted it to my associate so he could load it on the Mobile App...except he couldn't.

    I have been able to open it myself  in the App all along which working on it - except now that I'm finished, it doesn't open on my phone either!

    The App opens just fine, but then after clicking the form to load it, the poor little fellow on the bicycle keeps riding and riding and riding...and the App get stuck in that mode (won't exit properly at that point).

    I tried loginng out of the app, but when trying to log in again it tells me I have something wrong (I don't, I checked). I managed to use the Google login, but the same issue with the form not loading.

    Additionally, the form is "experiencing an error" when trying to sync for offline use - which is also a problem.

    1561949825Screenshot_20190630-225244.png

  • Profile Image
    Kiran
    Answered on July 01, 2019 at 03:59 AM

    As I check the form, I notice that there are 2143 fields on the form. I have cloned the form to my test account and was able to replicate the issue at my end on the Jotform mobile forms app. The issue seems to be with the length of the form which could be timing out to sync the form offline. 

    Let me forward the issue to our backend team for further investigation. If there is any news you'll be updated here on this thread. 

    Thank you!

  • Profile Image
    captainswallow
    Answered on July 01, 2019 at 07:43 AM
    Thanks for the update. FYI, the last time I tested the form before
    completion, it had at least 2100 fields in it and opened just fine in
    the app. The additional fields were not radically different - the only
    thing different was the SMOOTH SIGNATURE widget I added at the end.
    Might that be the issue?
    ---
    *Capt. John Swallow, Buccaneer*
    ~~Ventus Quod Aequora Rector Mihi~~
    http://pyratesimage.com
    http://pyratesunion.com
    http://nolapyrateweek.com
    http://twitter.com/captainswallow
    http://instagram.com/captainswallow
    ...
  • Profile Image
    captainswallow
    Answered on July 01, 2019 at 08:43 AM
    Tried removing the Smooth Signature widget, cleared cache (under
    Account/Settings), didn't seem to make a difference.
    There is a field just above it that should auto fill previous
    information from the first page of the form (Name/Job) - perhaps
    something else to look at.
    Website is still VERY laggy.
    ---
    *Capt. John Swallow, Buccaneer*
    ~~Ventus Quod Aequora Rector Mihi~~
    http://pyratesimage.com
    http://pyratesunion.com
    http://nolapyrateweek.com
    http://twitter.com/captainswallow
    http://instagram.com/captainswallow
    ...
  • Profile Image
    BDAVID
    Answered on July 01, 2019 at 10:48 AM

    Yes, it must be something else causing the issue in the mobile app. Probably, the amount of fields exceeds the max capacity that the app supports. We will need to wait for our developers to check this further, you will be notified via this thread if there are any updates.

  • Profile Image
    captainswallow
    Answered on July 01, 2019 at 11:43 AM
    Thank ye, I'm certain it's not the amount as it loaded previously. I'm
    convinced it's something in the last page where I used 2 special fields.
    ...
  • Profile Image
    stevenmarshall
    Answered on July 01, 2019 at 12:59 PM

    Hi @captainswallow,

    Thank you for the additional information. As my colleagues mentioned when there are any updates you will be via this thread.

  • Profile Image
    captainswallow
    Answered on July 02, 2019 at 08:43 PM
    Just checking in as I've had no further response for over 30 hrs. and
    nothing has improved.
    FYI, while I realize this is a long form (though in reality, almost
    entirely text), it takes about 20 seconds to load the edit page - which
    I could understand, however - it takes near 10 seconds to open the
    editing options for a single field (at the first page)...and another 10
    is I want to access the Properties". On a PC with 120 MBit, hardwired
    internet connection.
    ---
    *Capt. John Swallow, Buccaneer*
    ~~Ventus Quod Aequora Rector Mihi~~
    ...
  • Profile Image
    Nik_C
    Answered on July 03, 2019 at 02:17 AM

    Please be mindful that opening speed of your form doesn't have much to do with an Internet connection, as long as you have an internet connection any form will open.

    The speed of the loading depends mostly on how complex the form is, therefore, the speed depends on the Browser. Since all loading is done by the Browser.

    There isn't much we can do about that issue specifically, aside advising you to reduce the form size (fields/conditions used).


  • Profile Image
    captainswallow
    Answered on July 03, 2019 at 05:43 PM
    I've created a clone of the original form and removed a few of the
    widgets in case that was affecting it (form remaining, signature and
    HTML text with form fields).
    While it seems to sync OK, it still won't open in the App - FYI neither
    form will sync for offline use, it says (complete with spelling error):
    "An error occured while downloading the form. Please try again later."
    I've also just uninstalled the App, cleared phone cache and
    re-installed. It did eventually manage to load the clone it looked like
    it might load the original, but keeps pausing, then more pedalling.
    According to a support request someone else posted, there is no limit to
    the number of fields. The entire data download is only about 5 MB
    uncompressed.
    Seems like it's almost there.
    ---
    *Capt. John Swallow, Buccaneer*
    ~~Ventus Quod Aequora Rector Mihi~~
    ...
  • Profile Image
    BDAVID
    Answered on July 03, 2019 at 07:56 PM

    If the clone version loaded after deleting some widgets and fields, it could be that the app supports a specific amount of fields only. Not really sure though, we would need to wait for our developers to update us and fix the issue. They are looking into this, but there is no estimated time-frame for a resolution.

    By the way, thanks for letting us know about the spelling error, I'll let our developers know about it.

  • Profile Image
    captainswallow
    Answered on July 03, 2019 at 09:43 PM
    Appreciate the feedback.
    I did wonder if it was perhaps something in the App as it was only
    recently released from Beta - works great otherwise.
    ---
    *Capt. John Swallow, Buccaneer*
    ~~Ventus Quod Aequora Rector Mihi~~
    http://pyratesimage.com
    http://pyratesunion.com
    http://nolapyrateweek.com
    http://twitter.com/captainswallow
    http://instagram.com/captainswallow
    ...
  • Profile Image
    jherwin
    Answered on July 04, 2019 at 01:19 AM

    The issue is being worked on by our developers. As soon as we receive an update on this, we will inform you right away.

    Thank you for your patience :)