Voice Recorder Widget not working

  • Profile Image
    Wang_Victoria
    Asked on July 17, 2019 at 02:01 AM

    Hi there,

    I've already seen lots of questions and threads about this, but there doesn't seem to be a working solution.

    I have my jotform using the voice recorder widget, and I embedded it in my Squarespace website.

    The jotform works on jotform.com, but every time I try to use it through my website, I get this error:

    Could not access microphone: NotAllowedError: Permission denied

    Before we go back and forth, I have already tried the following:

    - gone to my MacOS system preferences and given Chrome permission to use mic

    - checked my Chrome privacy settings

    - quit Chrome and reopen it


    My theory is that Chrome's privacy settings are getting confused because, although it has given Jotform permission, it has not done so for SquareSpace. But every time I try to use it through Squarespace, Chrome doesn't ask me for permission because it has already asked Jotform.


    For all the other threads, you guys keep saying that you've fixed it. But there seems to be a trend that this is a continuous problem. I would really appreciate it if you guys could find a way to fix this.

    Screenshot
  • Profile Image
    jherwin
    Answered on July 17, 2019 at 03:21 AM

    We are sorry for the inconvenience this may have caused. Yes, it looks like the issue is with google chrome permissions. This prevents the permission to use the microphone on your webpage. However, I've tried your webpage using FireFox, enabled permission and it works.

    Could you please try to embed your form using the iFrame embed code instead of Squarespace embed code?

    Guide: Getting-the-Form-iFrame-Code

    Please give it a try and let us know how it goes.

  • Profile Image
    Wang_Victoria
    Answered on July 21, 2019 at 03:13 AM

    My website doesn't allow for iframe code unless I'm on the business plan. 

    Do you know of any alternative options?


    Thanks for your help!

  • Profile Image
    jherwin
    Answered on July 21, 2019 at 08:48 AM

    Please try updating your google chrome browser to its latest version. I tried opening your webpage and the video recorder widget works fine on my end that's why I can't pin down the issue. Also, please keep in mind that "permission to allow microphone" is needed/required in order for the widget to work.

    If you're opening your webpage through browser/phone, make sure your webpage's link is secure or you use HTTPS URL so that permissions pop-up will appear.