Form Loading slowly and halfway on some devices

  • Profile Image
    miahhend
    Asked on July 20, 2019 at 07:21 PM

    Hello, 


    I have 4 devices. 2 Androids and 2 iPhones. For iPhones I have to refresh the page twice to see the content and then everything works fine. However, for ANdroids, the start button will not actually do anything unless I tap it at least 3 times. Customers are complaining that theirs isnt workin at all or they're only seeing half the form questions.

    1563664505Image-1.jpeg 


    I know you guys are going to say its working fine on your end but I've literally been getting customer complaints for the past 3 hours. =( I assumed you guys were having server issues earlier since my iphones are loading just fine now.


    Unfortunately, androids are still having the click multiple times issue. & I've tried removing the 2nd condition but a user said she stills has the half screen issue unless she hit refresh. I believe she has the iPhone X.

  • Profile Image
    Kevin_G
    Answered on July 20, 2019 at 11:58 PM

    I have been testing your form and I can replicate the issue about the form not moving forward when clicking on the continue button as well as the slowness, upon checking your form I can see you're using several images which size is a bit large, for example, only one image is almost 5 MB: 

    15636811992019-07-20_21h52_11.png

    This impacts the form loading time in general, this means that the form is still loading while the user tries to move to the next page, I would recommend you to try reducing the size of your images and try if this helps with the issues you're facing, a form with the same features your form has works, but without images works fine. 

    There is not an specific size you need to have on your images, here is a link that may help optimizing your images for mobile: https://imagekit.io/demo/5-image-optimization-website-mobile-website-examples 

    If the problem persists, please let us know.