Why do some of my pages take a long time to load?

  • Profile Image
    ADCOLOR2019
    Asked on July 24, 2019 at 02:09 AM

    If you look at my form "Sponsor Guest List Form (Main)", how come pages 4-8 take a long time to load? This started happening earlier this evening but hasn't happened previously.


    Thanks!

  • Profile Image
    jherwin
    Answered on July 24, 2019 at 03:42 AM

    I tested the form you mentioned, but I was not able to replicate the issue you mentioned. The form loads quickly on my end, please check my screencast below.
    1563954098test.gif
    Please try with another browser as well. That may work. Or, try clearing your browser cache and cookies for Jotform first before opening the form.

  • Profile Image
    ADCOLOR2019
    Answered on July 25, 2019 at 02:03 AM

    I've tried clearing cache/cookies, using different browsers, and using different computers; and I'm still having issues with the pages taking almost 10 seconds to load. 

  • Profile Image
    jherwin
    Answered on July 25, 2019 at 03:45 AM

    The form quickly loads on my end. Perhaps a connection problem?

    Are you loading the form with the same network? Please try resetting your network or get a new IP address and see if that fixes the issue.

    By the way, I only have 5-6mbps download speed when I load your form: https://www.speedtest.net/result/8445355674.png, but I did not experience any issues.

  • Profile Image
    ADCOLOR2019
    Answered on July 25, 2019 at 12:48 PM

    So strange since we have 69 mbps download speed! Thanks for testing it!

  • Profile Image
    ADCOLOR2019
    Answered on July 30, 2019 at 06:08 PM

    Hi again! My colleague just tested the form and came across the same issue where the pages that include the configurable table lists are really slow to load. It seems to become slow after you've submitted one form and go back to submit another form. She's on a different network as well. Any idea why this would happen?

  • Profile Image
    ADCOLOR2019
    Answered on August 05, 2019 at 02:15 PM

    Hi! Following up on my question on 7/30 within this thread. Thx!

  • Profile Image
    roneet
    Answered on August 05, 2019 at 03:15 PM

    Yes, you are correct. I was able to replicate the issue if you fill-up the first Form to gain access to the second one.

    I noticed you are using the session method of saving and continue feature which is causing the slowness and you have built a long-form too.

    As you click the next page to save the newly entered data so it loads the Configurable list too which is in a separate iFrame. This is loaded independently and the data present in the widget is also refreshed to get the existing data if there is any which takes some seconds to load.

    If you test the direct URL of the Form, you would not able to replicate the issue.

    Thanks.