My conditions have gone crazy!

  • Profile Image
    pandcproductions
    Asked on March 12, 2013 at 01:55 PM

    I have a form with some basic conditions.  They have multiple rules but I am certain they have no contradictions and obey the rules of functions.  My form asks 3 questions and the combined answers from those questions give a unique response.  I have labeled the answers A, B, & C and the corisponding answers ABC.  This is only as a reference until we get this worked out.  Furthermore, I keep getting multiple answers for my selections.  Here is the link 

    http://form.jotformpro.com/form/30705011133940

    feel free to go in my account to verify that I don't have any contradictions.  Im sure you will see the problem right away.

     

    Thanks

  • Profile Image
    sidharth_kch
    Answered on March 12, 2013 at 02:40 PM

    @ pandcproductions

    I checked your conditions and dont see any issue with them. As there are a lot of conditions added(may have over looked), I am going to clone your form and check why its not working as expected.

    We will get back to you on this soon.

    Thanks,

    Sidharth

  • Profile Image
    pandcproductions
    Answered on March 12, 2013 at 02:42 PM

    thank you much

  • Profile Image
    Mike_T
    Answered on March 12, 2013 at 03:40 PM

    It seems that somehow the form conditions have mixed up.

    I have tried to fix the problem on the following form:

    http://www.jotformpro.com/form/30706015223945

    Please clone it to your account to see if you can start from that point. Thank you.

  • Profile Image
    pandcproductions
    Answered on March 12, 2013 at 05:15 PM

    whatever you did seems to be working.  Are you able to explain what you did so that I may try to do it to my original form.  The link I posted was actually a clone with all other fields deleted.  I don't want to start from scratch if I don't have to.  Thank you very much for figuring it out.

  • Profile Image
    Mike_T
    Answered on March 12, 2013 at 05:40 PM

    The problem seems to be related to the HTML codes on the 2A and 2B options. Conditions will probably not work if you have the codes like & in your options.

    You can try to do the following:

    1. Go to options of your 2nd question and change the HTML codes from & to standard symbol &

    From:

    A Standard Newsletter (Fixed Layout & Reports): $50 Setup; $35 / Month
    B Custom Newsletter (Custom Layout & Reports): $125 Setup; $35 /Month

    To:

    A Standard Newsletter (Fixed Layout & Reports): $50 Setup; $35 / Month
    B Custom Newsletter (Custom Layout & Reports): $125 Setup; $35 /Month

    2. Then you will need to fix some of your conditions. Please check at least:

    ABA
    BBC
    ABB
    ABC
    BBA
    BBB

    I hope that helps.