Odd problem importing into Xara WD6

  • Profile Image
    mikemahoney100
    Asked on March 27, 2011 at 11:54 PM

    I designed a form & inserted it into XWD6, no problem at first. Then I changed the size of a couple headings. Got the source code for the updated form, inserted it and it was the original form again. Tried again and again, even tried using a different color template, but every time I copied and inserted the new source code, I got the original form. Website has not yet been uploade to web so not available to see online.

  • Profile Image
    DanielGriffin
    Answered on March 28, 2011 at 09:19 AM

    Hi Mike,

    I see that you only have one form in your account so something must be getting stuck somewhere. 

    As a first step, can you confirm that the form is saving corectly and appears as you'd expect when you look at it directly?

    http://www.jotform.com/10850240149

    How are you inserting the code?  Is it via a Xara widget?  I found this excellent step by step guide on the Xara website that is specifically focused on JotForm integration.

    http://www.xara.com/uk/widgets/v6/designer/forms

    Failing this i'd suggest redoing the Xara page and pasting in the JotForm code again to make sure you remove anything thats unwanted.  but please do get back to me if you are still having difficulties.

    Thanks,

    Daniel

  • Profile Image
    Mike Mahoney
    Answered on March 28, 2011 at 12:03 PM

    Daniel, 

    Well, I did follow the Xara guide precisely and that did put the edited form onto my web page. However, a new problem now occurs: the form is chopped off on the right side. My form is set for 700px wide and the form as it is pasted into my web page slices off at 550px. I'm not trying to re-size the form after it is on the page, that is how it appears at the time it is inserted.

     Mike

  • Profile Image
    DanielGriffin
    Answered on March 29, 2011 at 09:31 AM

    Hi Mike,

    Sorry but I am not very familiar with Xara.  Is there anyway to edit the widget properties once it has been setup?  If the form is being partially hidden then that would suggest that its parent element in the page is not wide enough.  You might be able to specify that width somewhere else other than in the Xara code.  For example, if you could find the name of the element immediatly outside the form, then you could put some css code into your page to make it wider.

    Is it possible to put a copy of your code online?  Its difficult to diagnose the issue without being able to see anything.

    Thanks,

    Daniel